GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Jr. Mechanic drwdominance's Avatar
    Join Date
    Feb 2010
    Location
    Bowmanville Ontario
    Posts
    93

    Default hd trailer package problem

    Ok, 07 sierra classic which i have had for about 8 months which has the trailer package. bought a 17ft expandable travel trailer. the electronic brake control light is always on even without the trailer hooked up. so there is a problem with either the brake control unit or the trailer package.
    my question is how hard is it to diagnose the problem and what should i use to diagnose the problem?

    any insight?
    07 Sierra Classic, 5.3L, 4X4, Crew Cab
    Volant CAI
    Leveling Kit
    305/55/20 LTZ
    Flowmaster muffler
    Diablo Predator



  2. #2

    Default

    Disconnect the harness to the trailer plug and see if it goes out. What kind of controller is it?
    When you hear hoofbeats, look for horses not zebras.

  3. #3
    Jr. Mechanic drwdominance's Avatar
    Join Date
    Feb 2010
    Location
    Bowmanville Ontario
    Posts
    93

    Default

    Quote Originally Posted by 2COR517 View Post
    Disconnect the harness to the trailer plug and see if it goes out. What kind of controller is it?
    i will try that. it's a tekonsha voyager.
    07 Sierra Classic, 5.3L, 4X4, Crew Cab
    Volant CAI
    Leveling Kit
    305/55/20 LTZ
    Flowmaster muffler
    Diablo Predator



  4. #4

    Default

    If the light is on, there is a load on the controller. Could be corrosion in the trailer plug, or a bent pin.

    I hated my Voyager. Seemed like it was on or off.
    When you hear hoofbeats, look for horses not zebras.

  5. #5
    Jr. Mechanic drwdominance's Avatar
    Join Date
    Feb 2010
    Location
    Bowmanville Ontario
    Posts
    93

    Default

    Quote Originally Posted by 2COR517 View Post
    If the light is on, there is a load on the controller. Could be corrosion in the trailer plug, or a bent pin.

    I hated my Voyager. Seemed like it was on or off.
    so the way it is right now is that with no trailer hooked up the green light is on but when i touch the brake pedal the light goes out. it almost seems completely backwards.
    07 Sierra Classic, 5.3L, 4X4, Crew Cab
    Volant CAI
    Leveling Kit
    305/55/20 LTZ
    Flowmaster muffler
    Diablo Predator



Similar Threads

  1. 285/50/R20 Wheel and Tire package!!
    By SKEEBER in forum General Classifieds
    Replies: 0
    Last Post: 04-22-2010, 05:51 PM
  2. 2009 Suburban Trailer package question
    By 09mdburb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last Post: 12-08-2009, 05:32 PM
  3. Trailer light harness problem
    By 28sstony in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 08-06-2009, 04:19 PM
  4. How can I tell what package is in this Silverado
    By Georgethefierce in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 6
    Last Post: 07-10-2009, 01:52 PM
  5. Towing Package
    By vaburb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 18
    Last Post: 05-07-2007, 09:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •