GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Electrical Problem (need help)

    Just yesterday my friend was driving my 88 C1500 and it just turned off (while engine was running).
    I looked into the engine and found that the ground on the battery came off, as i put the cable back to the battery terminal it sparked more than normal and smoked. when i looked at the terminal i saw that it had melted (disformed) the battery terminal.
    Does anyone know what the problem might be?

    Any info will help, please and thank you!

  2. #2

    Default

    Well I would say that the maybe it was a one time thing. Is there anything completely wrong with it? Like will it start since the incident? If not, your starter might have shorted out. And if that is the problem, be careful taking it out. When I took out the starter and my dads Buick, I accidentally fried the alternator while taking the starter out, so it was a double fix. But it is an older truck and I could just be a one time thing. If it does it again, it could be a number of problems. Good luck!
    Ryan


  3. #3

    Default

    Thanks Ryan and after deep thought yesterday i came to that thought and now it feels good that i wasnt the only one thinking this haha. Again thanks a lot Ryan

  4. #4

    Default

    No problem! I hope all is good. These are great trucks and the will run as long as you take good care of them. I'm sure you have been and like I said, it might just be a one time thing. Good luck, and good trucking :P
    Ryan


Similar Threads

  1. Electrical Problem
    By tks20 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 03-07-2010, 09:00 PM
  2. Electrical Problem
    By bldawson89 in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 03-06-2010, 07:24 PM
  3. Electrical problem
    By '90_400 in forum Audio, Video & Gadget Tech
    Replies: 9
    Last Post: 12-08-2008, 08:53 AM
  4. Electrical problem - Please HELP!!!!
    By 540hp in forum Audio, Video & Gadget Tech
    Replies: 2
    Last Post: 09-27-2008, 04:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •