GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default truck having troubles starting

    i have a o7 silverado classic with a 6.0L i just had a brand new engine put in it and new battery and new starter but it wont turn over there is power goin to the starter kuz it tries to turn it but sounds like it just doesnt have enough juice there is plenty of power goin to the starter and it has a shim in it so the starter wont bind on the fly wheel but im at a dead end ha and losein my mind plz help

  2. #2
    Sr. Mechanic trapperdon's Avatar
    Join Date
    Feb 2010
    Location
    rainville ( Seattle )
    Posts
    169

    Default

    verify that both your battery & your starter are rated ABOVE what is needed to crank it over
    plus did you get it going before & it just started having problems or is this from the very beginning
    after dropping new engine in it? why DID you put new engine in it?
    are you sure that the shims arent too thick and not allowing it to bite enough?
    :fighting0037:
    when in doubt, doubletap !

    - buying a new truck, one part at a time :grrrrrr:
    94 Blazer 4x4 k1500 5.7 L - aftermarket cold air intake
    Energy Suspension swaybar & upper and lower control arm bushings
    Pro Comp ES 9000 front shocks, new front drive axles,
    stainless front brake rotors & new pads,
    new Moog front end ball joints, Smittybilt black nerf bar steps,
    MB Racing rims & Hankook ATm off road tires

  3. #3
    Jr. Apprentice
    Join Date
    Jan 2010
    Location
    Bountiful, Utah
    Posts
    14

    Default

    I would look into trying different shims, Also, Are you sure the new motor turns over properly? I would try to turn it manually with a ratchet on the crank pulley, if it doesnt turn that way then there is a motor issue.

    If it does, then re-shim and try again, and make sure the starter works in the first place, unbolt it and have it tested at a local parts store, or if there is enough cable to safely lay it on the ground while still hooked to the truck, then kick it over and see what you get
    96 Tahoe
    Flat tops
    LT4 cam
    2200 Stall
    Built trans
    3" exhuast
    Hypertech programmer
    255/70/17 BFG mud terrains

    And after all that it is still SLOW!!!!


  4. #4
    Sr. Mechanic trapperdon's Avatar
    Join Date
    Feb 2010
    Location
    rainville ( Seattle )
    Posts
    169

    Default

    was this a crate engine or did you put it together?
    was the distributor in it or did you have to line it up and put it in?

    - as an example on starter problems, alot of custom big block choppers have had
    issues of starting, and its cause they're so damn large that a standard starter
    wont crank out the torque to turn over the engine....
    it happens in high compression engines, gotta install compression releases... ( on choppers )
    :fighting0037:
    when in doubt, doubletap !

    - buying a new truck, one part at a time :grrrrrr:
    94 Blazer 4x4 k1500 5.7 L - aftermarket cold air intake
    Energy Suspension swaybar & upper and lower control arm bushings
    Pro Comp ES 9000 front shocks, new front drive axles,
    stainless front brake rotors & new pads,
    new Moog front end ball joints, Smittybilt black nerf bar steps,
    MB Racing rims & Hankook ATm off road tires

Similar Threads

  1. Fog light troubles...
    By Powercat91 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 07-08-2010, 10:58 PM
  2. troubles with a 98 diesel motor starting/running
    By renegaderider in forum GM Powertrain
    Replies: 4
    Last Post: 04-26-2010, 08:17 AM
  3. abs troubles
    By wadestevens in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 03-10-2010, 08:07 AM
  4. Truck Floods When Starting Warm Engine
    By ImpetuousNinja in forum Performance & Fuel
    Replies: 4
    Last Post: 05-30-2008, 10:59 PM
  5. Truck Not Starting
    By Crawdaddy in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 3
    Last Post: 09-04-2007, 01:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •