GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3

Hybrid View

  1. #1

    Default Wiring harness to fuel pump

    Hello,
    I need help from the community again.
    I have a 1997 Express 2500 van and I'm troubleshooting some fuel pump issues.
    I have replaced the pump that was intermittent in it's operation and still have no fuel pumping or hear the sound of the pump working. I have replaced the fuel pressure relay.
    Is there another fuse in the box under the hood?
    My diagram on the box lid is messed up and I can't read it.
    I noticed a section of the harness had been pinched against the frame and so I want to check those wires for the proper voltage.
    I have 4 wires in the harness.
    Black (largest wire gauge of the four)
    Black/White
    Purple
    Tan or Yellow (I can't tell exactly)
    Also, when I put in the previous pump about 2 years ago, immediately the fuel gauge would go back and forth when using the turn signal.
    With this new pump the gauge fluctuates the same way.
    Any help is appreciated!
    Thanks,
    Paul

  2. #2

    Default

    It sounds almost like a ground problem to me, with the turn signal/gauge issue.

    Get a manual for it, and check to see which wires are which. Check the ground (probably the straight black) vs the chassis with a multimeter and make sure it's not open (open = not connected to ground). Then check the feed wire with the key on (or while having someone turn the key on for you, as they'll cycle up and shutoff when pressure is achieved). If you have no power on the feed wire, then check at the relay and make sure it's outputting power when key is turned on.

    With electrical you just have to kinda work through it till you find the culprit. Multimeter and test light are your best friends
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

  3. #3

    Default

    Did you replace the pump only, or the entire sending unit?
    When you hear hoofbeats, look for horses not zebras.

Similar Threads

  1. Low Voltage at fuel pump harness
    By alchemist1 in forum GM Electrical Tech
    Replies: 3
    Last Post: 11-16-2011, 07:46 AM
  2. Fuel pump issues, wiring?
    By cj5daddy in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 03-20-2010, 05:54 AM
  3. Wtb: Wiring harness
    By JOHNNYBLACKEYE in forum General Classifieds
    Replies: 0
    Last Post: 02-08-2010, 11:16 AM
  4. Wiring Harness
    By MPB7000 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 11-12-2009, 08:48 PM
  5. Wiring harness
    By ONETONMIKEK30 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-08-2008, 10:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •