GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Unhappy 97 Flasher problems!!!

    Ok, I'm pulling my hair out and don't have any to spare! I have a 97 Silverado 1500, Ext. cab, 5.7, etc. I now have a problem with my flashers: they work fine (left, right, and hazards), UNTIL I press the brake pedal. When I press the brake, I hear something (I assume a relay) buzz for about 1/2 a second and then flashing stops and all brake/marker lights are on solid (front and rear).
    I've replaced the flasher relay (under hood), the brake light switch, and finally the flasher arm assembly (in the steering column). I'm at a loss for what to do next! Any help is much appreciated!

  2. #2
    Sr. Mechanic trapperdon's Avatar
    Join Date
    Feb 2010
    Location
    rainville ( Seattle )
    Posts
    169

    Lightbulb

    sounds like you have a bad bulb / wire to the brakes & tail light.
    everything fine till you step on brake? you've got an overloaded condition
    that is surging max power to the lights in the turn circuit, kinda jumping accross the path...

    have you tried changing out BOTH of the tail light bulbs?
    oh, do you have an aftermarket tail light or accent cover on the brake lens? check those.
    some wire or piece of metal is bridging the gap to the turn signals from the brakes
    :fighting0037:
    when in doubt, doubletap !

    - buying a new truck, one part at a time :grrrrrr:
    94 Blazer 4x4 k1500 5.7 L - aftermarket cold air intake
    Energy Suspension swaybar & upper and lower control arm bushings
    Pro Comp ES 9000 front shocks, new front drive axles,
    stainless front brake rotors & new pads,
    new Moog front end ball joints, Smittybilt black nerf bar steps,
    MB Racing rims & Hankook ATm off road tires

  3. #3
    Jr. Mechanic
    Join Date
    Mar 2010
    Location
    Montana
    Posts
    134
    Blog Entries
    1

    Default

    Do you pull a trailer with it try checking to make sure you dont have any wires for the trailer plug shorting out.

  4. #4

    Default Update

    Hey guys, thanks for the suggestions! Just an update on the problem, as it's been quite a while since I've messed with it... When either turn signal is on, both sides flash in the rear, and only the correct one in the front. But when I press the brake, all flashers stay on solid. Don't know if that changes anything...
    Anyway, all light bulbs work and flash like they should. I also replaced the "boards" the bulbs plug into this morning. I don't pull a trailer with any regularity, and that was my first suspicion when this problem started. I found what I would call the trailer wiring tee (where the wiring comes to the back to the wide, flat plug, one side goes to the R, the other L), and there was an inline plug going to my trailer 4 pin. I pulled that out first thing.
    It sounds like it's a trip to the mechanic, be damned if I have to chase wires all the way up and down that thing... Anybody want to buy a truck in KC?

Similar Threads

  1. Flasher module
    By GSPKurt in forum GM Electrical Tech
    Replies: 1
    Last Post: 06-27-2010, 10:57 AM
  2. Equinox flasher [Expired Topic]
    By KevinJJ in forum Chevy Equinox Forum (GMC Terrain)
    Replies: 2
    Last Post: 05-24-2010, 10:42 PM
  3. Flasher relay problem 06 gmc sierra
    By scooter11 in forum GM Electrical Tech
    Replies: 1
    Last Post: 01-20-2010, 03:20 PM
  4. Flasher/turn signal problems - New relay in need?
    By Springthing in forum Audio, Video & Gadget Tech
    Replies: 6
    Last Post: 12-30-2008, 01:28 PM
  5. 04 silverado LED conversion (flasher?)
    By identityPRS in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 09-04-2008, 05:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •