GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Hybrid View

  1. #1

    Default Hard to steer and Poor Braking, HELP!!

    Hello everyone! I just bought a 2003 Silverado 2500 W/T with the 6.0 and auto trans. The guy i bought it from recently had the power steering pump replaced as it was getting hard to steer. Apparently that didn't fix the issue, so he sold it to me.
    I checked for any obvious vacuum leaks and didn't find anything. The issue is that whenever you're driving slowly (or the engine is at idle) it is insanely hard to steer, and the brakes get mushy. The main issue for me is the crazy hard steering. If you give it a little gas the power assist will generally come back. He said it had something to do with the brake booster, that they're somehow linked, i've never seen that, so i'm a bit puzzled.
    Anyone heard of this??? I really want to get this resolved ASAP
    Thanks EVERYONE!!!!!!

    It should also be mentioned, the power steering fluid is not low. It does have a bit of a whine to it when sitting, revving and turning the wheel, nothing ridiculously loud, but certainly present...
    Last edited by riponfrosh; 06-17-2010 at 04:34 PM.

  2. #2
    Sr. Engineer
    Join Date
    May 2009
    Location
    Manitowoc, WI
    Posts
    400

    Default

    What rpm does it idle at? My first thought is if there isn't enough vacuum and the power steering only works when you give it a little gas is its idling too low.

  3. #3

    Default

    idle was at 1000rpm when i just started it up, couldn't turn wheel... that idle is certainly high enough to maintain proper power steering assist... thanks though!!

  4. #4

    Default

    Steering box grinding? joints everywhere okay? Lines clogged up? Try flushing your lines out. Vacuum leaks, basic things to check for.
    www.youtube.com/ippielb
    2002 Chevrolet Silverado 1500 z71 1985 Chevrolet Silverado k10 2006 Chevrolet Silverado 2500hd 6.6l LLY Duramax
    6.5" BDS Suspension Lift Edelbrock Carb & Polished Intake Manifold & Valve Covers NAPC Race Transmission & NAPC Built Transfer Case
    EFI Live Comp Cam and Valvetrain Snow Performance Methanol Injection
    35" Toyo Open Country Mud Terrain on 18" Ion Alloy 179's Headman Long Tube Headers and True Dual Exhaust FASS 150gph Titanium Series Pump
    AirAid Cold Air Intake with K&N Dry Filter & AirAid PowerAid Throttle Body Spacer 2" Suspension Lift 33x12.50r15 Tires EFI Live & AFE Stage 2 Intake
    Pacesetter Long Tube Headers with Cats Gone True Dual Exhaust FlowPro 3.73 Gears Yukon Grizzly Locker with Mag-Hytec Cover & Traction Bars
    NGK Iridium Tips & MSD Ignition Plug Wires Baja Spare Tire Holder 33x13.5 Hankook rt03 18" XD Rims
    Innovate LC-1 Wideband o2 Sensor x2 HID's all around LED taillights and 3rd brake light
    BDS Dual Steering Stabilizers Pioneer Double-DIN Touchscreen Navigation with Two 10" Subs under rear seat
    Electric Fan Autometer Pressure, Boost, and Pyro Gauges
    4.56 Gears Airlift Air Bag Suspension

  5. #5

    Default

    The truck must have HydraBoost power brakes. Steering and braking assist are both from the power steering pump.

    If the pump is OK, there must be some blockage in the lines, steering box, or brake booster preventing flow. I don't know much about them, so I can't offer much more information.
    When you hear hoofbeats, look for horses not zebras.

  6. #6

    Default

    It is a hydraboost, at least i think it is at it's different than anything i've seen. The power steering lines run up to where the brake booster "should" be.
    I've been hunting around for vacuum leaks. I've found that if I remove the pcv valve from the valve cover it has NO effect on the idle. maybe that's how these run, but i'm used to that causing the engine to stumble. Same with removing the oil filler cap... removing it has no effect on the idle. Usually the loss of vacuum will cause irradic and poor idle.
    Idle looks like about 600 once it settles down. It runs great other than the power steering/ brake issues.

    EDIT: After looking around, it appears the "hydraboost" system doesn't really run on vacuum at all... so i don't believe a vacuum leak to be the culprit.
    Last edited by riponfrosh; 06-17-2010 at 05:41 PM.

Similar Threads

  1. 1998 Suburban-2wd 1500-Hiss-poor braking-Power brake booster.
    By phoebeisis in forum Lifted & Offroad Suspension
    Replies: 9
    Last Post: 10-04-2013, 08:13 AM
  2. 03 Quadra Steer "Service 4 Wheel Steer"
    By meash20 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 11-19-2012, 08:50 PM
  3. poor idling and hard start on s10 blazer
    By 2wheelmudder in forum GM Powertrain
    Replies: 6
    Last Post: 07-08-2010, 11:01 PM
  4. torque steer
    By hbfsbull in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 01-02-2010, 12:39 PM
  5. My poor brain, help!
    By LisaO925 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last Post: 09-04-2009, 01:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •