GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Thread: Steering Issue

  1. #1
    Jr. Mechanic
    Join Date
    Oct 2009
    Location
    Fairbanks, Alaska
    Posts
    76

    Default Steering Issue

    This is a problem that I've had for two summers. It only does this in the summer for some reason. When I'm either driving very slowly or stopped sometimes I cannot turn my steering wheel. The pump seems to make the same sound that the steering pump makes when you have the wheel turned too far one way when I am turning it just slightly off top dead center. I'm still capable of steering it, but it feels manual, instead of assisted.

    I've checked to see if the fluids were low, and the color. I just don't know what's going on. Also, I've brought it in to place that I have my service agreement with and they could not replicate the problem.

    Any help is appreciated
    /***********************************
    2006 Chevy Silverado 5.3L Z71 Crew Cab
    Additions:
    Viper Auto Start / Security System
    PIAA 520ions ( Mounted in grill now )
    Magnaflow Cat-Back
    6000K HID Low Beams
    Homemade Projectors
    Definitely more to come
    ***********************************/

  2. #2

    Default

    I recently had a similar problem with one of the trucks at work, ours would make the dash alarms go off also.
    We had the pump replaced and the problem didnt go away but it doesnt happen as often now.
    Our service center told us they've been seeing a higher rate of power steering pump failures lately.
    I'm dont know if the 1/2t trucks have an inline sensor for power steering pump pressure, Diesels and 1t's do have them and this causes a dash light and alarm.

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by tbplus10 View Post
    I recently had a similar problem with one of the trucks at work, ours would make the dash alarms go off also.
    We had the pump replaced and the problem didnt go away but it doesnt happen as often now.
    Our service center told us they've been seeing a higher rate of power steering pump failures lately.
    I'm dont know if the 1/2t trucks have an inline sensor for power steering pump pressure, Diesels and 1t's do have them and this causes a dash light and alarm.
    I dont believe they do.. And i had a powersteering pump failure on my 2006 C1500.. Similar problem but mine was hard to steer when it got warm.. The problem was less noticable with a new pump but as Tbplus said with his trucks it never really went away...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4
    Jr. Mechanic
    Join Date
    Oct 2009
    Location
    Fairbanks, Alaska
    Posts
    76

    Default

    Thanks tbplus10 and murdog94. It seems like there is nothing I can do. I feel as if I should just wait to see if it gets worse. I don't want replace anything and not fix anything.

    Thanks Again
    /***********************************
    2006 Chevy Silverado 5.3L Z71 Crew Cab
    Additions:
    Viper Auto Start / Security System
    PIAA 520ions ( Mounted in grill now )
    Magnaflow Cat-Back
    6000K HID Low Beams
    Homemade Projectors
    Definitely more to come
    ***********************************/

Similar Threads

  1. A.C. Issue!
    By Mike01Suburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 16
    Last Post: 07-19-2010, 09:08 AM
  2. Power Steering Issue (Maybe)
    By Alaskan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 04-21-2010, 08:05 PM
  3. 2500HD steering issue
    By wiqidss in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 04-16-2010, 12:18 PM
  4. Issue with 4WD
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 12-21-2008, 09:26 PM
  5. Steering Issue
    By Dixt635r in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 05-28-2008, 07:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •