GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default codes PO300 PO332 and PO453 help please.

    Hi I was looking for some opinions. Just recently a couple of codes and the SES light came up on my 2000 Silverado Z71 with the 5.3. PO453 Evap system pressure high has been on for a little time now and I believe has nothing to do with the other two. I tried the easy fix of replacing the gas cap but the code came right back on after clearing the codes. My main concern right now is the PO300 Multi cylinder misfire and PO 332 Knock sensor circuit low. Both of these last two codes came on at the same time, shortly after I washed down the engine compartment. The truck is misfiring with low power between 1500 and 2000 rpms any higher RPM and it seems to run fine. Where do yall think I should start with this problem? Could it be that the knock sensor got wet and is causing the misfire or the other way around? Also I have tried clearing all the codes but they all come back after running it three times.

    Thanks in advance
    Brian
    Last edited by ouimetteracing; 06-23-2010 at 09:41 PM.

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    I have read on here that the knock sensor can get wet.. I think that was on the 5.7L engine.. But that might be at least a place to start and hopefully someone with a bit more knowledge of the 5.3L will be able to chip in...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. po332 code knock sensor moister problem help!!
    By burb4us in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 08-19-2009, 10:41 PM
  2. info - misfire on a 2001 chevy tahoe 5.3 code PO300
    By x1078p in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-18-2009, 11:47 PM
  3. Yet another PO300 question
    By J-wall in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 07-27-2009, 06:41 PM
  4. 99 yukon 5.7 121,000 po300
    By bigred14 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last: 02-27-2009, 08:04 PM
  5. Help With Codes Po171, Po300 And Freeze Frame Data
    By jcwells in forum GM Powertrain
    Replies: 5
    Last: 02-20-2009, 09:45 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •