GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Thread: Hello there

  1. #1

    Question Hello there

    Just a quick hello from Saskatoon, Saskatchewan, Canada. I have a 2007 Chevy Classic Silverado Crew Cab 1500 4x4 Z71. Just going to take a quick peak for any info on replacing brake shoes

  2. #2

    Default

    hi,what are the problem?

  3. #3

    Default

    To the Site....

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  4. #4

    Default

    The problem at the time was trying to figure out how to deal with the bottom "spring" on the brake shoes. I've only ever dealt with an '89 Chevy (my old truck) so this one was a bit new, but I finally just used some force with some water pump pliers and got it going. Now after doing all my brakes (did the front ones yesterday, new pads and turned the rotors, had the drums turned today), my brakes are super soft. I have enough fluid and they don't feel spongy like you'd expect if there was air in the lines (I never opened any lines, so not sure how that would happen anyway). I have to pretty much put my foot to the floor before it starts braking. Trying to figure out if I somehow missed something.

    By the way, yes I realize that moisture/dirty brake fluid will cause weak brakes, but what is confusing me is the brakes had better pressure with the old worn out brakes than they do now with the new pads/shoes. Actually, tested the brakes after replacing the front pads and it was fine, it has only been since I replaced the shoes. I've braked several times in reverse as I'm pretty sure that is how the shoes self adjust. I will most likely flush the system anyway, just confused right now. Maybe I didn't hook the self adjusting mechanism properly and it's not adjusting? Will have to try and google for some pictures, but when I was changing the shoes, I did one side at a time and tried to make sure everything looked the same as the other side that was not changed. Any thoughts anybody?
    Last edited by KroBaar; 06-25-2010 at 07:26 PM. Reason: Added more info.

  5. #5

    Default

    Welcome to the GMTruckClub!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  6. #6
    Legend
    Eddie Z71's Avatar
    Join Date
    Mar 2009
    Location
    Colorado Springs, CO
    Posts
    3,838
    Blog Entries
    1

    Default

    Hi, and welcome to the site!
    Eddie , 2000 Chevy Tahoe Z71 (old style)

  7. #7
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Welcome aboard.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  8. #8

    Default

    Welcome!!!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •