GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 15
  1. #1

    Default DIY - Correcting the P0430 Code

    My truck (97 Silverado Z-71) is due for Inspection here in PA...they do emission testing.

    I've had a CEL illuminated for a few months, so I need to fix the problem prior to Inspection.

    I went by Autozone and had them run the codes for me, and it was P0430 (Bank 2). From the research I've done it looks like it's either the Cat or the O2 Sensor.

    The truck has 178k miles on it, and the Cat's are original equipment. I've changed one or two of the O2 Sensors a few years ago, but i'll be damned if I can't remember which one's I replaced!!

    I understand from reading that you can test the O2 Sensors, but I don't know what tool I need for that...so, please enlighten me! also, wouldn't hurt to explain the procedure for testing if you have the time.

    I'm assuming this should be done first, and after testing, if I find that all O2 Sensors are good, then I should look at replacing the Cat...right?

    Many thanks in advance for your help!

    -ruger
    My Truck:

    1997 Chevrolet Silverado Z-71 ExtCab
    *picture soon

  2. #2

    Default

    A couple of different ideas:

    1) Switch the post cat O2 sensors left to right and see if the code follows the sensor or not. If the code follows the sensor, the sensor/circuit is probably at fault. If the code stays the same, the cat is probably at fault.

    2) If you have a scanner (more than a code reader, you need one that can monitor PID"s), you can monitor the post cat O2 sensor data. Post cat sensors should not have a lot of variation in the reading.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  3. #3

    Default

    Quote Originally Posted by MrShorty View Post
    A couple of different ideas:

    1) Switch the post cat O2 sensors left to right and see if the code follows the sensor or not. If the code follows the sensor, the sensor/circuit is probably at fault. If the code stays the same, the cat is probably at fault.

    2) If you have a scanner (more than a code reader, you need one that can monitor PID"s), you can monitor the post cat O2 sensor data. Post cat sensors should not have a lot of variation in the reading.
    will the code reflect the swapping immediately? in other words, if i swap the o2 sensors after work today, would i be able to test the code immediately afterwards?? and if the code switches to Bank 1, then I know to replace the post cat o2 sensor on Bank 2, correct?

  4. #4

    Default

    It might not show up immediately after the first drive cycle (be sure to clear the code after switching sides). It's been a couple of years since I dealt with this code on mine, but, as I recall, it often took a few drive cycles for the exact set of conditions that trigger the P0420/P0430 codes to occur reliably. It might take a couple of days for the CEL to come back on and set the code.

  5. #5

    Default

    Quote Originally Posted by MrShorty View Post
    It might not show up immediately after the first drive cycle (be sure to clear the code after switching sides). It's been a couple of years since I dealt with this code on mine, but, as I recall, it often took a few drive cycles for the exact set of conditions that trigger the P0420/P0430 codes to occur reliably. It might take a couple of days for the CEL to come back on and set the code.
    that may pose a problem for me...you see, i just registered my truck up here in PA, and was notified i had 10 days to get the truck inspected. i'm thinking of going ahead and replacing the post cat bank 2 o2 sensor, and having the code cleared...the shop will probably tell that the codes been cleared and give me a time frame to bring it back in, maybe somewhat of a grace period. ughhh, what a beating...

  6. #6

    Default

    okay...i'm having major problems just trying to remove the old o2 sensor...the first socket was the long cylinder type, with the slot for the cable...it didn't work because of the location of the post cat bank 2 sensor. i then bought a $28 socket, that is short, but has the slot...fits on like a charm, but can't seem to break the damn sensor loose!!!! HELP!!!

  7. #7

    Default

    Quote Originally Posted by rugerjitsu View Post
    okay...i'm having major problems just trying to remove the old o2 sensor...the first socket was the long cylinder type, with the slot for the cable...it didn't work because of the location of the post cat bank 2 sensor. i then bought a $28 socket, that is short, but has the slot...fits on like a charm, but can't seem to break the damn sensor loose!!!! HELP!!!
    Run the truck and get the pipe/sensor hot. They are almost impossible to get apart cold...sometimes he threads will 'gall' and strip out when cold IF you can get it to move...

    I've also unplugged the wire and slid it thru a box wrench to break 'em loose when warm...if you have room
    Still Loyal to GM after all these years...:shocked:
    2006 Impala LT 3.5L
    2005 Silverado WT small cab/longbed 4x4 4.3L V6
    1999 Grand Am 3.4L in TX w/ our youngest
    1993 GMC Jimmy 4.3L 4 door 4x4 'Ole Rusty' - 'SOLD'
    1988 S-10 small cab/longbed HT3.4L Crate Engine
    1970 Nova 250 I-6, factory 3 sp floor shifter.
    1968 Chevelle 'Nomad' Wagon 250 I-6 w/ 3 on da' tree.

  8. #8

    Default

    Okay, so last night I finally broke the o2 Sensor loose!!! I tried last week two nights, only about 10-15 minutes of actually trying...i used two different o2 sensor sockets, and both failed misserably...one of them i couldn't even figure out how to use!

    Last night, i tried using a simple adjustable crescent wrench...sprayed the sensor down with some WD-40, and got the engine warm. It finally broke loose, and actually felt like i stripped the damn thing at first! i reached up there, and was able to unscrew it with my hand after the initial break. replaced it with the new o2 sensor, and drove down to autozone to have them erase the code...

    i'll be taking it to get inspected today, so i'm keeping my fingers crossed everything goes smoothly! they said it could fail due to having erased the code so recently, but if so, i'll have a 30 day time limit to bring it back for another emmissions test for free...wish me luck!

    thanks for all the feedback guys...

  9. #9

    Default

    Quote Originally Posted by rugerjitsu View Post
    Okay, so last night I finally broke the o2 Sensor loose!!! I tried last week two nights, only about 10-15 minutes of actually trying...i used two different o2 sensor sockets, and both failed misserably...one of them i couldn't even figure out how to use!

    Last night, i tried using a simple adjustable crescent wrench...sprayed the sensor down with some WD-40, and got the engine warm. It finally broke loose, and actually felt like i stripped the damn thing at first! i reached up there, and was able to unscrew it with my hand after the initial break. replaced it with the new o2 sensor, and drove down to autozone to have them erase the code...

    i'll be taking it to get inspected today, so i'm keeping my fingers crossed everything goes smoothly! they said it could fail due to having erased the code so recently, but if so, i'll have a 30 day time limit to bring it back for another emmissions test for free...wish me luck!

    thanks for all the feedback guys...
    It will almost certainly fail. It takes several drive cycles before all the I/M monitors are complete. Like you say, though, the idea is to get that 30 "extension".

    One thought, if you can get a hold of one, most scanners (maybe not the bottom of the line code readers) can check the I/M monitors and tell you when they are all complete, so you'll know when to take it back in for the re-inspection.

  10. #10

    Default

    I am so glad I live in a part of Pa. that has no emissions testing.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Need advice: 99 Silverado radio shorting and p0430 issues
    By Robzilla! in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 11-10-2009, 05:32 AM
  2. Code P0430
    By scoobysteven in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 10-18-2009, 02:50 PM
  3. Trouble code P0430
    By Narti in forum GM Powertrain
    Replies: 3
    Last: 04-13-2009, 08:44 PM
  4. Conditions for setting P0430 question
    By MrShorty in forum GM Powertrain
    Replies: 6
    Last: 03-24-2009, 04:08 AM
  5. DVD NAV Code
    By MFR in forum Audio, Video & Gadget Tech
    Replies: 4
    Last: 03-27-2008, 02:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •