GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1

    Default Need Help I Stumped........

    I threw the scan tool on my 2004 Silverado since its showing me the check engine light, and it doesn't bring anything up, the scan tool is brand new and I have used it on my fathers truck as well as my brothers but it wouldn't bring anything up on mine. Advanced Auto Parts told me that a fuse might be blown inside and i checked all of them and their all fine a need help to know what to do next to get the scanner to work......thanks in advanced for any and all hep

  2. #2

    Default

    Anything ?

  3. #3
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    Is the scanner communicating with the truck? If not check the cigarette lighter fuse as that is also the fuse for the OBDII system.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  4. #4

    Default

    my cig lighter fuse isnt workin aswell all fuses inside are fine checked all is it one under the hood and thatnk u sir for the reply

  5. #5
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    Fix the cigarette lighter power problem and then you should be able to pull some codes.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  6. #6

    Default

    done and threw the scanner on it i dont remember the code something like PO+++ and a bank 1 sensor 1 came up i replaced the O2 sensor on the passenger side and the code comes up again after i drove it could it be the O2 sensor on the driver side and/or the cat??
    Last edited by Oakley10289; 07-02-2010 at 11:31 PM.

  7. #7
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    Could be the driver side sensor. It would be best to get the code and do a quick search either here or on google so we would know for sure.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  8. #8

    Default

    put new batteries in my scanner now it works lol the code code up as.....P0135 02 Heater Circuit (Bank 1, Sensor 1)

  9. #9
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    No idea on that one.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  10. #10

    Default

    Bank 1 Sensor 1 is the oxygen sensor on the drivers side that is in front of the catalytic converter.

Similar Threads

  1. Please Help, I am Stumped
    By dawolfman in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 8
    Last Post: 06-06-2010, 10:01 PM
  2. Stumped on 97 GMC Jimmy problem
    By exceler8 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 09-30-2009, 08:08 AM
  3. Stumped
    By nsanders in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 06-17-2009, 11:34 PM
  4. Stumped two mechanics with popping in truck
    By LisaO925 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 8
    Last Post: 05-19-2009, 09:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •