GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Transmission issue- 1995 Tahoe

    My 1995 Tahoe started acting up yesterday. 350, 4l60, 4x4, 4 door. The linkage from the shifter to the trans has a lot of play, which I need to deal with. My wife put the truck into reverse to leave and there was an issue, no go. I went underneath the truck and pulled the linkage off the trans to run through the gears manually(by hand). When the vehicle is placed in reverse, it wants to go forward, like a normal forward gear. Anyone experience this? or know the problem? Thanks.

    ---------- Post added at 03:33 PM ---------- Previous post was at 03:31 PM ----------

    Also- no problems shifting, no slippage, nothing. Now this.

  2. #2

Similar Threads

  1. 1995 Silverado Starting Issue
    By Skro in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 05-02-2010, 12:54 AM
  2. Automatic Transmission Issue?
    By chevytruckman in forum GM Powertrain
    Replies: 3
    Last: 11-15-2009, 04:45 PM
  3. 4L60 transmission issue
    By mug23 in forum GM Powertrain
    Replies: 8
    Last: 05-30-2009, 09:23 PM
  4. Transmission Removal Tips? 1995 Subrubran
    By Breadfan in forum GM Powertrain
    Replies: 4
    Last: 04-22-2009, 11:29 AM
  5. 1995 gmc sonoma high rider 4x4 transmission??
    By aquaholic in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 0
    Last: 12-13-2008, 02:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •