GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Electrical issues with 1998 Chevy Silverado k1500

    I have a 1998 Chevy Silverado ext cab K1500 with the 5.7 vortec engine. Just recently the winshield wipers stopped working. In order to get them to work, I have to turn them on and then give the wiper a yank and they will start working. Does this sound like a wiper motor issue? The reason I figured out to yank on them to get them to work was I could hear the motor wining.

    Yestarday, I turned on my lights and the dash lights did not come on. I played around with the dimmer and it had no effect. Could this be a fuse?

    It has not happenned recently, but I have been driving down the road with the A/C on and then all of a sudden it turns off and then a second or 2 later it turns back on.

  2. #2

    Default

    Have you checked your ground wires.

  3. #3
    Jr. Apprentice
    Join Date
    Jun 2010
    Location
    Philadelphia, PA
    Posts
    19
    Blog Entries
    1

    Default

    you may want to check the grounding of your fuse panels. But also make sure you do a thorough check of your wiring harness from the battery all the way into the truck and up above your feet at the pedals to make sure it hasn't been damaged in anyway. As far as the wiper modor, they run somewhat like a gear and teeth operation. The mother has the gear with teeth meshing together with the actual wiper arm. you may need new motor gear or wiper arms. JUNKYARD buddy, heavy snow and rain will have a damaging effect on those things over time obviously. Your dash lights could be a loose harness, check connections. A/C could be another grounding issue, just take the time to check things over before wasting money to take it somewhere to get diagnosed, i promise you'll be pissed if its something simple you overlooked and pay for it.

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    Have you checked your ground wires.
    I second checking out the grounds etc.. But it does sound like the circut board in the wiper motor may be done for. It was a common problem on our body style trucks.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5

    Default

    I had issues witht the Wipers not wanting to work...

    Turned out to be the Wiper Switch in the steering column.

    Dash lights and Head lights are run from the same switch assembly.

    I also had some problems there, changed out the switch, no more problems.

    A/C issue could be any number of things.

    Blower Motor Resister is a common failure part.

    There is also a compressor clutch switch that can get worn out over time.

    Just my .02, for what it's worth...
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

Similar Threads

  1. 1996 K1500 Electrical Issues
    By SilveradoBrett in forum GM Electrical Tech
    Replies: 6
    Last Post: 11-28-2011, 01:44 AM
  2. 2000 Silverado C1500 Electrical issues
    By 99vortec in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 01-03-2010, 08:50 PM
  3. Electrical Issues
    By Steve in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last Post: 12-03-2008, 08:52 PM
  4. 1980 silverado stepside electrical issues
    By 80stepside in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 11-16-2008, 10:55 PM
  5. 1998 Chevy 4 X 4 K1500
    By hankms in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 12-16-2007, 10:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •