GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Recent Head Gasket Replace. Won't Start Just Turns.

    I just recently did a whole gasket replace set. Head gaskets and everything. Recently put everything back together in my 96 Suburban C1500 2wd, and I have fuel spark and compression. The only thing that I can think of is that its some kind of timing issue but its computer controlled in my model so I have no idea how to adjust this. Lines for the plugs are all in order (double triple checked) and I've seen some articles elsewhere on something about the cam and crank sensors being the problem.

    I've also looked around here and saw some advice about a coolant pressure sensor, but it doesn't seem to be flooding outright. Just not timed so flooding happens when we crank it over. I dunno I'm lost

    Also

    New to GM trucks and first big project on this baby, so any pointers would be awesome

    ---------- Post added at 12:13 PM ---------- Previous post was at 10:24 AM ----------

    Btw just some supplemental info

    The whole process started when the car was running unusually hot. It's had head gasket troubles in the past apparently (previous owners informed us of this) and it wasn't going too bad so we added some stop leak to it. Worked just fine for a while then the radiator blew. We replaced the radiator and all was well for about 4-5k miles later and the overheating issue reappeared. Have regularly watched the oil mixture through it all and caught it mixed with water before any real wear was put on the thing.

    Set about to do the head gasket replace with a gasket kit. Took it apart and replaced all the gaskets from head to lower and upper intakes, oil pans etc. First problem was after we put it all back together we had gas and spark but no compression. A friend suggested that the valves may be stuck so I took it all apart again, cleaned and reseated the valves and replaced the stem seals. Put it all back together for a second time, that fixed the compressions problem but still don't have any firing.

    As I said this whole thing Is my first big project on a truck. Have done a fair amount of work on other stuff but never gone so far as to tear down an engine so this is all new to me.

    Any ideas?
    Last edited by derbs1129; 07-24-2010 at 10:21 AM.
    Derbs... aka demo derb :)

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Timeing... You will need to get it close.. If you search the forum you will find a few telling you how to do this.. did you return the motor to #1cyl TDC before you took the motor apart? If not you will want to research about the engine timing and it will give you detailed instructions on how to time it out right.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I think Murdog is right on with his diagnosis, pull the plugs and roll the crank around until you can verify your TDC on #1 cylinder then start all your checks to verify positions. You could be 180 out.
    Are you getting any backfires or misfires when you turn the engine over?
    I'm also wondering how you checked spark, I assume for fuel you've checked the plugs and found them wet.

    The following post's have links to maintenance/repair manuals, like I said before Chiltons or Hyanes are good. Just follow their directions on setting timeing.
    Something I always have to make myself do when facing a problem like this is to follow the directions completely, dont start at step 2 or 3 because you already know that particular item has been checked or adjusted, lots of times it's the one little step I was assuming on that ends up being the problem.
    Good luck and let us know what you find.

    http://www.gmtruckclub.com/forum/sho...lton-site-link
    http://www.gmtruckclub.com/forum/sho...ars-and-trucks.

Similar Threads

  1. turns but will not start
    By Jeremy.kayla in forum GM Powertrain
    Replies: 5
    Last: 07-19-2010, 11:05 PM
  2. head gasket?
    By 97chev in forum GM Powertrain
    Replies: 8
    Last: 01-02-2010, 10:04 AM
  3. '95/'96 454 ??s - Oil pressure & head gasket
    By omnisi in forum GM Powertrain
    Replies: 1
    Last: 03-15-2009, 11:27 AM
  4. 5.3 head gasket ??
    By FireRed in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 07-06-2008, 12:05 PM
  5. engine turns over, but won't start [Expired Topic]
    By whitestonian in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 11-25-2006, 03:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •