GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Unhappy 1997 Suburban problems

    I recently replaced the fuel pump, twice, after the truck has been driven for about 20 minutes or longer and I shut it off and try to restart it , it will not restart until it cools off. sometimes that is 12 hours or more. Ido not know what to try next , any one have an idea what I could try next ? 5.7 V8... 250,00 miles...........

  2. #2

    Default

    If you put a fuel pressure gauge on it when you try to start it, how much pressure is there? I might also try pulling codes to see if there are any DTC's that might help point to the problem.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  3. #3
    Sr. Mechanic trapperdon's Avatar
    Join Date
    Feb 2010
    Location
    rainville ( Seattle )
    Posts
    169

    Default

    just thinking out loud here...
    what have you replaced besides the fuel pump? when's last complete tune up & timing adjustment ?
    have you checked out the condition of your oxygen sensor and cat converter?
    is it the TBI ? pop off the air cleaner and get inside and tighten down the torx bolts inside,
    they will work themselves loose and create a leak...
    check condition of all the small diameter vacuum lines / hoses.
    do you still have the heat shield on the side of the starter?
    we need a little more input on what symptoms are and what condition of repair you rig is...
    have you changed out the fuel filter?
    :fighting0037:
    when in doubt, doubletap !

    - buying a new truck, one part at a time :grrrrrr:
    94 Blazer 4x4 k1500 5.7 L - aftermarket cold air intake
    Energy Suspension swaybar & upper and lower control arm bushings
    Pro Comp ES 9000 front shocks, new front drive axles,
    stainless front brake rotors & new pads,
    new Moog front end ball joints, Smittybilt black nerf bar steps,
    MB Racing rims & Hankook ATm off road tires

  4. #4

    Default fuel pump

    Quote Originally Posted by MrShorty View Post
    If you put a fuel pressure gauge on it when you try to start it, how much pressure is there? I might also try pulling codes to see if there are any DTC's that might help point to the problem.

    Thanks, for the info. I went to ehow.com , they told me to replace the fuel pump relay , my suburban works great, thanks again...........

    Thomas

    ---------- Post added at 12:37 PM ---------- Previous post was at 12:32 PM ----------

    Quote Originally Posted by trapperdon View Post
    just thinking out loud here...
    what have you replaced besides the fuel pump? when's last complete tune up & timing adjustment ?
    have you checked out the condition of your oxygen sensor and cat converter?
    is it the TBI ? pop off the air cleaner and get inside and tighten down the torx bolts inside,
    they will work themselves loose and create a leak...
    check condition of all the small diameter vacuum lines / hoses.
    do you still have the heat shield on the side of the starter?
    we need a little more input on what symptoms are and what condition of repair you rig is...
    have you changed out the fuel filter?


    Thanks for the info, some one told me to replace the fuel pump reley, it seems to have solved the problem........... Thanks again

Similar Threads

  1. Problems with flashers. k1500 1997
    By kungen08 in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 10-31-2009, 10:43 AM
  2. My 1997 suburban ls
    By bsharles in forum Photo & Video Gallery
    Replies: 1
    Last Post: 08-01-2009, 06:07 PM
  3. 1997 Suburban
    By suburban34 in forum Member Introductions
    Replies: 6
    Last Post: 01-02-2009, 11:59 AM
  4. 1997 5.7 liter Suburban.
    By gtrvsb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 06-04-2008, 09:37 AM
  5. 1997 K2500 5.7 Transfer Case: impending problems?
    By eb2143 in forum GM Powertrain
    Replies: 0
    Last Post: 01-02-2008, 06:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •