GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 2007 Chevy Avalanche Z71 NO parking lighst

    Hello guys, I just picked up a 07 Chevy Avalanche and it has a few electrical issues. First of all the parking lights, along with the tail lights do not turn on. Headlights work, brake lights work and so do blinkers. When I pull out the parking light relay and put a jumper wire in the spades I can get them to come on, when I put it back in then I get nothing. I know its not the relay because I have tried several different relays and it makes no difference. Also the oil pressure gauge does not work. The tire pressure monitors do not sync. And "stabiltrac off" will flash on the screen when I am driving it down the road. Any Ideas? Thanks

  2. #2

    Default

    You need to test the circuit that operates the relay. Probably 2 circuits.

    One would be the relay coil circuit, this circuit would include the BCM (body control module), a ground source and a 12v source. The BCM acts like the switch. The circuit probably has a fuse to operate the relay. 2 fuse panels, under the hood and inside the dash (driver's side, door open).

    Them, we have the circuit(s) that tells the BCM to switch on these parking lights.Turning the headlight switch to PARK should be enough to tell the BCM to operate the relay. This circuit is usually a ground. A ground through the switch position that is applied to a pin on the BCM.

    I'd check the fuse(s) first.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •