GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 98' Silverado Wiper Motor Buzzing, Wipers don't work.... Any ideas?

    So on my way to work this morning I tried using my wipers, but all I got was a buzzing/humming sound coming from what sounded like the wiper motor. Any ideas as to what the problem may be? I did a little research and some people said it may be the solder connections are cracked. Or could it be the motor is bad and I should just replace that?

    Thanks,

    Doug
    Thanks,

    Doug



    -98' K1500 (See Above)
    -96' K1500 (Gone)
    -89' Cherokee Lifted/rigged (Sold)

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Id shoot for a wiper motor.. Welcome to one of the most common problems on the GM trucks of our generation. You could try and tap it with a hammer (lightly) if you need it to get you home...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    About ten years ago my wipers quit working on my '96 Suburban. If I rememmber correctly it was a elec. board and not the wiper motor. Appearantly this was a common problem. Sorry but I can't remmember what the board was called. There was a GM bulliten back then.

  4. #4

    Default

    We had an identical problem on my(then my mother's) '94 Suburban. The motor would turn if I whacked it with a wrench, but would sometimes freeze right in the middle of a cycle. Replaced the motor about six or seven years ago and haven't had another problem.

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    About ten years ago my wipers quit working on my '96 Suburban. If I rememmber correctly it was a elec. board and not the wiper motor. Appearantly this was a common problem. Sorry but I can't remmember what the board was called. There was a GM bulliten back then.
    OH SOB i forgot about the circut board.. yeah its built into the motor it has a black flat plastic cover on it... Thanks Silver....

  6. #6
    Sr. Apprentice
    Join Date
    Sep 2010
    Location
    B.C. Canada
    Posts
    39

    Default

    This was called the windshield wiper pulse board. Replaced alot of these.

  7. #7

    Default

    Curious if you've got it fixed yet Doug?

    My GMC is doing the same thing, stopping and buzzing, but sporadically and I want to get it fixed before the fall rains start...

    Also curious how hard it is to get to the wiper motor - I haven't had a chance to look yet.
    -Berg
    1998 GMC Sierra 1500 Ext Cab 4x4

Similar Threads

  1. wiper motor wiggin out
    By 03 Black Sunshine in forum GM Electrical Tech
    Replies: 2
    Last: 05-01-2010, 12:43 PM
  2. wipers dont work.
    By seffieldvillage@aol.com in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 5
    Last: 11-02-2009, 09:31 AM
  3. Wiper motor confusion on 03 silverado
    By nvyseal11 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 04-17-2008, 01:41 PM
  4. 93 suburban wiper motor
    By GRIFF in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 03-22-2008, 01:36 PM
  5. new wiper motor?
    By 95CTburb19 in forum GM Powertrain
    Replies: 2
    Last: 12-16-2007, 03:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •