GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Morningtime sputters

    Every morning, after my truck has sat for several hours... it sputters on startup. The rest of the day its fine.
    I've run injector cleaner through it, and on a bottle of HEET now...

    Any ideas?
    Matt
    Wichita Falls, TX
    2007 Chevy Silverado 1500 Classic LS 4x4, 4.8L
    Thrush Welded muffler, dual exhaust
    HELO MAXX6 18" Rims, Torza Tri Fold tonneau cover :glasses:

  2. #2
    Sr. Engineer
    Join Date
    Aug 2009
    Location
    Virginia Beach, VA.
    Posts
    337

    Default

    IAC maybe??

  3. #3

    Default

    hey guys i just wanted to get this back on the top of the list since it really wasnt answered. Mainly because i'm really curious as to what caused the problem for mvoss since i had the same exact issue when my truck was brand new. I took it back to the dealer several times under warranty and they said they couldnt figure it out! the problem went away, but i've always wondered what it was.

    mvoss, any update?

    Brian
    Brian
    Frederick, MD
    1995 Chevy truck
    223,000 miles and counting

    :fighting0098: chaos, panic and destruction...my work here is done

    GM ALL THE WAY BACK
    2007 Chevy Imp
    2006 Chevy Colbolt
    2007 Suburban
    1986 Camaro
    1996 Saturn
    1999 Saturn
    1996 Oldsmobile
    1995 K1500

  4. #4

    Default

    Sounds like a leaky injector, leaks down after setting and floods that cylinder. May be a few injecters. Try putting a pressure gauge on and see if the gauge goes down after shutting off engine. If it does its most likely a dribbling injector.

  5. #5

    Default

    Brian - no update on what is causing this yet on my end.. some mornings are worse than others.
    What is an IAC? And where would I put a pressure gauge on?
    Truck has just over 100k on it, and just started in the last 3k miles or so... also about the time the weather really started heating up.
    Matt
    Wichita Falls, TX
    2007 Chevy Silverado 1500 Classic LS 4x4, 4.8L
    Thrush Welded muffler, dual exhaust
    HELO MAXX6 18" Rims, Torza Tri Fold tonneau cover :glasses:

  6. #6
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    The IAC is the Idle Air Control valve. It is on the throttle body and can get a chunk of carbon in it, and or else just a sluggish servo.
    As to the leaking injector. There should be a port that you install a Fuel Pressure guage up on the intake. But with the high temps i would for sure check the fuel pressure!
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. PLEASE HELP! Egine bogs/sputters with gas only when warm!
    By 02silveradoZ71 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 09-26-2009, 12:04 PM
  2. Truck just sputters then cuts off without warning
    By crane3447 in forum Performance & Fuel
    Replies: 8
    Last Post: 08-24-2009, 03:18 AM
  3. 1990 burb, sputters off idle
    By myolbug in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 10-06-2008, 02:15 AM
  4. engine sputters and pops at highway speed
    By gmc4life in forum GM Powertrain
    Replies: 7
    Last Post: 08-14-2007, 10:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •