GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default A few questions about my new 2003 Yukon XL 2500

    Hi all,

    New owner of a 2003 Yukon XL 2500 4WD SLT. I have a few questions:

    1. There's a sound like a small electric motor when I turn the key on, that seems like it's coming from mid to rear of the truck. It just turned up this morning, I haven't heard it in the last week. It comes on with the key, engine running or not. It lasts until I turn the key off, when it winds down and stops. The climate control is turned off front and rear.

    2. I don't seem to be getting 12v power from the 7-pin trailer connector's charge line. Is there something I need to install to enable this?

    3. The previous owner installed an AUX input in the dash using some sort of adapter device interfaced to the head unit, but I haven't been able to figure out how to use it. The head unit is the stock 6CD changer with XM radio. Any ideas on what might have been installed before I open up the dash to look at the device?

    4. Is there a way to have the fogs come on with the headlights?
    Last edited by stubble; 08-13-2010 at 10:48 AM.

  2. #2

    Default

    Welcome to the GMTruckClub! As for your problems, you might get more help in the different sections within the list of forums. Are sure the "fan noise" you have is not the electric fuel pump? The "Aux input" is probably for your I-Pod or other MP3 player. Good luck!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  3. #3

    Default

    The small elec. sound is most likely the fuel pump. If you just started to hear it maybe the fuel filter is getting glogged and needs to be replaced.

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    The small elec. sound is most likely the fuel pump. If you just started to hear it maybe the fuel filter is getting glogged and needs to be replaced.
    X2 on that...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5

    Default

    Thanks. I bet you're right. The next day I couldn't hear it. I'll look at the fuel filter.

    I figured out the trailer thing: There was a red blank fuse in "Stud#1", the blank labeled "B+". I put a 40A fuse in and bingo, 12v power at the 7-pin.

    Also figured out the AUX thing, sorta: The device is a DPX GM12-AUXV2. It's operated by select XM and then switching it on and off by going to CH 1 and selecting up and down while track up / track down. This toggles the bypass, and the AUX works great. However XM pulls in no audio. The radio activated and got the channel listing, but says "no signal". I presume the aux device is the culprit. For now I'm content with a line-in. Sounds great.

  6. #6

    Default

    I have a 2011 GMC Yukon... The radio keeps jumping from fm to Aux Input D and back again and is driving the nuts!! Is there a way to turn on and off the Aux input

  7. #7

    Default

    Cragreen10,

    Oh no! I am sorry to learn that you are experiencing an issue with the radio in your vehicle. I cannot give any technical advice but I would like to look into this for you. Please private message if I can be of any assistance.

    Regards,

    Jennifer T.
    GM Customer Care

Similar Threads

  1. 2003 vs 2005 Suburban (or Yukon XL)
    By jbeall in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last: 11-29-2012, 08:03 AM
  2. 2003 Envoy XL SLT 5.3L V8 Questions
    By cmurphy84 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 12
    Last: 10-05-2010, 12:16 PM
  3. 2003 GMC Yukon A/C Problem
    By bullitt3683 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 06-28-2010, 04:27 PM
  4. 2003 yukon need a/c wiring diagram please !
    By crisafi75 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 06-24-2010, 10:31 AM
  5. Some questions about yukon 1997
    By Bartimaeus226 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last: 07-23-2007, 12:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •