GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Jr. Apprentice
    Join Date
    Jul 2010
    Location
    San Antonio, TX
    Posts
    23
    Blog Entries
    2

    Default Promblems in the dash?

    Ok now that i fixed the other electrical problem I am back to the original. My oil pressure gauge goes haywire. From time to time the speedo, and tach decide to join in too. When it really starts acting up the parking indicator light turns off, and the transmission will not shift into over drive. Just had the tranny replaced, and replaced a bad body ground. Looking for possible solutions.

    Tabor

    1995 K2500 454

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Either the Guage cluster or else the PCM is going bad.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3
    Jr. Apprentice
    Join Date
    Jul 2010
    Location
    San Antonio, TX
    Posts
    23
    Blog Entries
    2

    Default

    I was looking on line for instrument clusters and cant seem to find one any sugestions on places to look?

  4. #4

    Default

    Maybe a bad ECM is why the transmission had to be replaced.

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    Maybe a bad ECM is why the transmission had to be replaced.
    X2!! i actually missed the tranny replacement and thought it said you didnt want to.. thanks for correcting me as well Silver. Id lean that way seeing as you have already had problems.
    Also with the guage cluster ususally i go to a junk yard.. and a cluster from a 1995-1999 out of any GM Fullsize truck will actually work...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. starting promblems on 98 tahoe
    By Bobby1021 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 02-15-2010, 03:05 PM
  2. In-dash help
    By nickpatton_189 in forum Audio, Video & Gadget Tech
    Replies: 9
    Last Post: 11-03-2009, 03:14 AM
  3. chevy silverado dash vents dash part ac heat vents
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 10-15-2009, 06:00 PM
  4. In-Dash
    By nickpatton_189 in forum Audio, Video & Gadget Tech
    Replies: 5
    Last Post: 08-16-2009, 07:55 PM
  5. No dash!!!
    By twisty774 in forum Audio, Video & Gadget Tech
    Replies: 0
    Last Post: 03-24-2008, 01:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •