GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Question gmc yukon 5.7 l bogs down at 55 on interstate

    my 2001 gmc yukon 5.7l v8 bogs down at 55 on the interstate it will hit the passing gear and freeze up at a hard 2000 rpm and will not go over 55 mph and if you hold it to the floor you will hear a loud pop in the pass floorboard but if you back off the gas it will chane gears in not have that high rev lock but then it will slowly pick up to a lil over 55mph and on other days i will drive like a new one i had the cats removed sue to a mechanics advice and new plugs installed also the egr valve cleaned there are no codes showing on the scanner im lost on what to do and on the days i can do 70+ on the interstate and have the cruise set you can feel a rise in rpms then the drop in them with a slight back and forth motion i think i have a problem with fuel system well if you have any answers on the boggin down i woul really apperciate them

  2. #2

    Default

    Sounds like your cat.converter is gloged up !!!!!!

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  3. #3

    Default

    but if you notice i said i had the cats removed when it first started actin this way it helped a lil but not enough

  4. #4

    Default

    Quote Originally Posted by gillian_blake View Post
    but if you notice i said i had the cats removed when it first started actin this way it helped a lil but not enough
    Removing Cats on late model Vehicles.....Can do more Harm,than good.....I would Scan the truck again.....just to be sure No codes are present.....also What brand of Spark plugs were installed??



    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  5. #5

    Default

    i put NGK R plugs in they told me they where the hottest plugs i could put in th car that fixed the miss fire on number 1 cil and after i removed the cats that cleared the cat code but i still had a egr code remaining so i took it off and cleaned it with carb cleaner and that code vanished so there are no codes showin on my suv as of now but the loss of power don't start till i and on the road for a while but if i pull over and chill for like 20 min it will clear up for bout 30 min or sometmes wont act up till another day

  6. #6

    Default

    I just cleared up a similar problem on my 97 chevy 5.7 vortec. My problem was very random and I could make the problem go away by shutting the engine down and restarting it.The engine would then run fine for a while. No codes were stored and the problem was intermittent so it was hard to figure out where to start. I finially decided to check EACH sensor supplying data to the PCM. I disconnected each connector and cleaned the pins and receptacles wiyh crc electrical contact cleaner and reconnected the connectors.I then removed the 5 connectors on the pcm and carefully cleaned both pins and recptacles and reseated all connectors.(make sure battery is disconnected before removing connectors on PCM)MY ENGINE JUST CAME ALIVE ,it has never run this good and the problem has not returned to date.I guess considering the low voltages the computer works with(.5 volts and less)it doesn't take much dirt on some or all of the connector pins to really throw things off.I cleaned the following connectors: TPS, MAP, CKP, MAF, TCS, and all 4 O2 sensors plus all the connectors on the PCM.

  7. #7

    Default

    Doesn't it throw O2 sensor codes with the cats removed? Also I would replace those NGK's with factory spec A/C Delco plugs. There have been many members on this site that have tried other brand plugs and had problems. They went back to A/C Delco's and cleared up the problems.

  8. #8

    Angry

    well after puttin the NGK plug si got better gas milage and have not thrown any codes from the cats being removed so i still dont know

  9. #9

    Default

    Well, sorry i did not read all of it ..lol But if u remove your cats and it does not throw a O2 sensor code,,something in that matter has to be wrong unless u have a sensor delete installed !
    But the thing with cleaning all the conections on each and every sensor and what not is a good idea, i need to do that aswell.......more to do for me next week.
    Hope i get better results too,,,although my truck runs fine now!!!
    Wonder what these plugs would do in my 96 ??? mmmmhhhhhh

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  10. #10

    Default

    im gonna try to clean every thing tomorrow but if there are any more ideas i would like to here them and would like to know whats the quickest way to get a little lift outta my yukon keep in mind it has coils all the way around and independant susp on th front

Page 1 of 2 12 LastLast

Similar Threads

  1. Truck bogs between 45-50 mph
    By RAM_Z in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 03-01-2010, 09:51 AM
  2. NO POWER!! Bogs down!
    By Avatar in forum Performance & Fuel
    Replies: 5
    Last Post: 01-12-2010, 01:56 PM
  3. 97' bogs out on take off and highway
    By kober in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last Post: 12-17-2009, 03:57 AM
  4. Crash closes part of Interstate 80 - WQAD
    By Steve in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 0
    Last Post: 01-22-2008, 07:03 PM
  5. Replies: 0
    Last Post: 06-16-2007, 11:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •