GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Thread: Bad clutch?

  1. #1

    Default Bad clutch?

    I just picked up a 95 Silverado with standard tranny. It runs great, but sometime it will not go into 1st that well. I found if I put the clutch in all the way to the floor it goes in. Could this be a sign I may need to replace the clutch? Also it seems to engage when the clutch pedal is almost all the way out. Any one have experience with this and know how much a replacement might cost? Thanks for all the input!

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Sounds like the clutch is getting weak. Also the 1st gear syncro could be worn. If it doesnt slip, i would run it till it quits.
    I paid $500 or so for a new one to be installed in my 1988. So i would imagine around that price is what you would pay if someone where to do it for you.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I was thinking it may be getting weak, it does not slip or anything like that so I will run it till it does. $500 is not as bad as I was expecting! Thanks for the input!

  4. #4

    Default

    Welcome to the club.

  5. #5

    Default

    Thanks! It looks like some great info on the site with some good people! Glad to have a bow tie also!

  6. #6
    Jr. Mechanic
    Join Date
    Apr 2010
    Location
    Ortonville MI
    Posts
    136

    Default

    Also check your master cylinder to make sure its full of oil if its low you could be getting air in the line to the slave which wouldn't allow the slave to fully release the clutch. It is located by your brake booster should be black and mounted to the fire wall.

    07 NBS Crew cab SLT 4x4

  7. #7

    Default

    Also, see if you can adjust the pedal linkage. It might just have worked loose.
    ...
    ....

  8. #8

    Default

    I will check the master cylinder and try to adjust it this weekend. Thanks for the input!

Similar Threads

  1. clutch job
    By bucklti in forum GM Powertrain
    Replies: 0
    Last: 03-05-2010, 08:42 PM
  2. How do I know if my fan clutch is bad?
    By OldPitPony in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 09-27-2009, 10:17 PM
  3. Clutch fan to electric?
    By Tiny1987 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 07-01-2009, 07:18 PM
  4. Fan Clutch help
    By Dr_Zero in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 03-30-2007, 08:18 AM
  5. Fan Clutch running at 100%????
    By mustangrog1979 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 3
    Last: 02-16-2007, 09:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •