GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 93 Suburban wont run right when cold/ and restart when hot

    Hey i Jason. I am a machinist for a race car shop outside of Cincinnati and during race weekend i am at the track as a tire changer. I have owned a 1993 K1500 suburban for about 5 years. Last year with about 247,000 miles the original motor broke a lobe off of the crank. Luckily my dad had a motor that was out my grandpa’s 1983 suburban. The motor was pulled out and built. About 2 months later my grandpa wrecked the suburban. According to my dad and uncles the motor only has about 2,500 miles on it and this is what has been done to it

    bored .40 over, racing cams, light weight crank, pistons, valves, lifters, rockers, aluminum heads. complete performance exhaust

    Since doing the motor swap the suburban has been driven about 2,000 miles. I doesn’t like running when it is cold. Until the motor get up to temperature it doesn’t like to respond to throttle and when coming to a stop it wants to die. And as of recently when I drive it for like 15 or 20 min and then turn it off it will not start back up for like 45 or 50 min. Any suggestion on what the problems might be would be greatly appreciated. thank you
    Last edited by murdog94; 09-16-2010 at 11:13 PM.

  2. #2
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    Hi Jason,You would probably get some good help with your engine problem if you posted this in the powertrain tech department on the forum main page.Good luck and welcome to the club!
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

  3. #3
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Welcome to the site....Unfortunately, I cannot make any suggestions, but I am sure someone will be able to.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  4. #4
    Legend
    Eddie Z71's Avatar
    Join Date
    Mar 2009
    Location
    Colorado Springs, CO
    Posts
    3,838
    Blog Entries
    1

    Default

    Hi, and welcome to the site!
    Eddie , 2000 Chevy Tahoe Z71 (old style)

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    *****thread moved here*********
    welcome aboard and moving it here should get you some great response, and if you have any questions about the move please PM me.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  6. #6

    Default

    You might try advancing the timing a little bit. If you're running TBI, they're pretty particular about that.
    ...
    ....

  7. #7

    Default

    Please post more details about your setup. Carb or fuel injected? Could have bad idle air control, timing could be off, vacuum leak, or fuel pressure/plugged filter/ other fueling issues. sounds like an air control or fueling issue though.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

  8. #8

    Default

    The motor is fuel injected; it has a new fuel pump, filter and lines. And it does not throw up a check engine light

Similar Threads

  1. Chevrolet : Suburban LT 2000 Chevy Suburban Monster Truck All Custom
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 08-22-2010, 04:50 PM
  2. Chevrolet : Suburban LT 2000 Chevy Suburban Monster Truck All Custom
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 08-11-2010, 08:50 PM
  3. Replies: 0
    Last: 11-16-2009, 11:40 AM
  4. Chevrolet : Suburban 2000 Chevy Suburban MONSTER TRUCK FULL CUSTOM
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 07-28-2009, 01:00 PM
  5. Replies: 0
    Last: 07-14-2009, 10:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •