GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default Diablo Predator... and now my truck won't idle.

    Bought and installed the diablo predator u7193. The truck ran normal before installation. I followed the instructions, backed up the factory setup, and installed the 87 Octane Program. Now the truck idles LOW, down to 250-350 range and dies if any load is put on accessories. If I program the idle to be higher, it idles to that set RPM after 10 seconds or so, but still falls down to about 250-350rpm if I change from park to reverse, to drive, etc. This often causes it to die again. If I shut the truck off with the A/C left on, it won't start without my foot on the gas.

    So basically, the program messed up the idle characteristics of the engine. Here's the fun part; I then gave up and programmed the "return to stock" setup, and everything went good supposedly (according to the predator). Started the truck up and everything is the SAME as when it had the 87 octane program. So it completely lost the factory stock program.

    So what can I do? I believe there is someone on here who makes programs for these tuners, would you be willing to help me out please?

    Thanks for the help guys,
    Blake

    ---------- Post added at 04:33 PM ---------- Previous post was at 04:25 PM ----------

    Not sure if it makes a difference, but the driver information display showed "Reduced Engine Power" AFTER installing the tune. I figured it was just because the Predator changes fuel settings, but now I'm second guessing it.


    '03 Black Silverado Z71 Ext.

  2. #2

    Default

    06MonteSS is Lew, he does R&D for them. Try him at diablewtune.com or at this site at 06MonteSS.

  3. #3

    Default

    From what I was told, the "reduced engine power" message is normal while installing tunes with the Diablo. Personally, I think it's your truck because it does the same thing with and without the tune. If it idled rough only while the DSP was hooked up and the 87 Octane Tune was installed, I'd lean towards the DSP causing the problem, but with your truck acting the same after you return it to stock, I'm leaning towards it being your vehicle. Try some MAF Sensor Cleaner and Throttle Body Cleaner. I had a similar problem a few weeks back where the truck would start up but anytime I put it into gear, the truck would idle really rough and act as if it wanted to shut down. I bought some CRC MAF Cleaner and CRC Throttle Body Cleaner from autozone and the truck runs fine now. You will be surprised with what a good cleaning will do for the truck.
    2003 Silverado 2500HD 6.0L Vortec V8
    2" Body Lift
    3" Suspension Lift
    Skyjacker Hydro 7000 Shocks
    Skyjacker Steering Stabilizer
    35" Tires with 20" American Racing Rims
    Velocity Cold Air Intake
    Billet Throttle Body Spacer
    BBK Performance Headers
    MBRP Cat-Back Exhaust System
    DiabloSport Predator- Soon to be tuned by Diablew

    "Soon to be leveling-kit"

  4. #4

    Default

    I'll give it a shot either tonight or tomorrow sometime, thanks! I also have some new plugs waiting to go in (truck is at 107,000 on what I believe are factory plugs).

    It just seems ironic that the truck started acting up as soon as I loaded the first tune. :-/ but anyways I'll definitely clean the TB and MAF as soon as I get a chance.

  5. #5

    Default

    Well a minor problem may have been there but the tune made it show up. Kinda like when we would lift a truck with miles on it and after the lift the truck would shake going down the street because it had worn out balljoints, tie rods etc.. and the lift with the larger tires made the little front end problem that the owner didn't notice into big problems that you could feel. Hope I explained that right.

    ---------- Post added at 07:00 PM ---------- Previous post was at 06:35 PM ----------

    I see you are changing your spark plugs. Because of the Aluminum heads I always let the truck sit overnight so I know the engine (heads) are completely cool so the chance of stripping the threads out are lessened. Also use anti-seize on the new plug threads. One last thing. Most people on this site have found that the stock factory A/C Delco plugs work best.

  6. #6

    Default

    Quote Originally Posted by BlackMagic View Post
    I'll give it a shot either tonight or tomorrow sometime, thanks! I also have some new plugs waiting to go in (truck is at 107,000 on what I believe are factory plugs).

    It just seems ironic that the truck started acting up as soon as I loaded the first tune. :-/ but anyways I'll definitely clean the TB and MAF as soon as I get a chance.
    If you have never cleaned the MAF and/or Throttle Body, you may have a lot of build up at 107K miles. I'm under 81K and my throttle body was disgusting when I took off the intake and started to clean it. I used a toothbrush to scrub inside the throttle body and placed a rag underneath the opening so the run-off didn't drip on the engine. The toothbrush came out black from all the carbon.

  7. #7

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    Well a minor problem may have been there but the tune made it show up. Kinda like when we would lift a truck with miles on it and after the lift the truck would shake going down the street because it had worn out balljoints, tie rods etc.. and the lift with the larger tires made the little front end problem that the owner didn't notice into big problems that you could feel. Hope I explained that right.

    ---------- Post added at 07:00 PM ---------- Previous post was at 06:35 PM ----------

    I see you are changing your spark plugs. Because of the Aluminum heads I always let the truck sit overnight so I know the engine (heads) are completely cool so the chance of stripping the threads out are lessened. Also use anti-seize on the new plug threads. One last thing. Most people on this site have found that the stock factory A/C Delco plugs work best.
    Wow man everything you said was exactly my plan. I have the factory AC delco plugs sitting here, the truck is sitting tonight and I'll do it tomorrow after work. And I believe either my plugs or wires came with anti-seize. I really appreciate the info, as I decided all of that because of researching these forums ;)

    Metaluzc- I would imagine there hasn't been any TB or MAF cleanings, I have only had the truck for about 1,500 miles.

    Thanks guys, I'll be doing this soon and will post here as to the result.

  8. #8

    Default

    do as these other bright fella's have mentioned already... ^ ^ ^ clean your MAF... when doing the new plugs, also do new wires, and make sure they are all on securely....

    so, what tune is in the truck right now??? and what does the predator show if you go to Options > Show Last Tune Written ???
    06MonteSS


    2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake

  9. #9

    Default

    Well guys I cleaned the MAF, cleaned the TB (NEEDED it bad), and slapped on the new plugs & wires yesterday. Problem fixed ;) I greatly appreciate all the help!!! You guys rock!

  10. #10

    Default

    Glad that you got it fixed.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Diablo Predator Question
    By c_m_chance in forum Performance & Fuel
    Replies: 25
    Last: 10-24-2011, 09:33 AM
  2. Diablo Predator Owners in NC?
    By grrr... in forum Performance & Fuel
    Replies: 3
    Last: 09-14-2010, 07:05 AM
  3. Diablo Predator
    By USN-MA2 in forum General Classifieds
    Replies: 8
    Last: 06-14-2010, 01:26 PM
  4. Diablo Predator Tuner and 5.3L
    By KC8QVO in forum Performance & Fuel
    Replies: 7
    Last: 04-03-2010, 03:49 AM
  5. WOW!! Diablo Predator Tuner
    By Velocity1 in forum Performance & Fuel
    Replies: 12
    Last: 09-21-2009, 07:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •