GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    Default Bad Throttle Response..Doesnt accelerate like i want it to

    alright, heres the deal. i have good throttle response if i dont floor it. but if im cruising and every now and then i wanna feel the power, i floor it. but it seems as if it barley accelerates. its like im better off pushing the petal slowly. its like an off and on thing. sometimes it wants to take off and most of the time it doesnt....

    any ideas? had a tune up not to long ago. this year. (fuel filter, plugs, plug wires, oil change w/filter as well, seafoamed) also changed the PVC valve, fuel regulator, TPS)


    ---------- Post added at 10:41 PM ---------- Previous post was at 10:40 PM ----------

    i also have a CAI and custom exhaust with magnaflow

  2. #2

    Default

    Try cleaning the MAF with CRC MAF cleaner, don't use throttlebody cleaner on the MAF. Make sure its MAF cleaner. CRC is the only MAF cleaner that I've seen. Its in a silver can.

  3. #3

    Default

    should i disconnect the battery as well to reset the ECU?

  4. #4

    Default

    Never hurts to disconnect the battery when working on the truck. Also I would take off the throttlebody and clean with CRC throttlebody cleaner and a SOFT old toothbrush.

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Also taking a look at your fuel pressure wouldnt hurt since it seems that when you floor it the pressure isnt there.. Also a Throttle position sensor sweep test would probably be a good idea since a weak or bad TPS can also rear its ugly head and when you stomp on it the TPS doesnt tell the computer that you have the throttle opened all the way.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  6. #6

    Default

    yeah i was planning on cleaning the throttle body as well because i have to take the intake off anyways haha. and the TPS i changed about a couple months ago. but doesnt hurt to check it

  7. #7
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    It never hurts since im pretty sure the vast majority would agree its not the first time that a replacement part failed.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  8. #8

    Default

    alright i finally got everything running great! then a week later, it goes back to where it was....
    Last edited by Silverado1500; 09-28-2010 at 08:34 PM.

  9. #9

    Default

    i can be going at a steady speed and when i give it gas, it accelerates slowly barley increasing rpms staying around 2000 till i floor it, then it gives some power

  10. #10
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    What did you do to repair it?
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Page 1 of 2 12 LastLast

Similar Threads

  1. lag in throttle response
    By wilk in forum Performance & Fuel
    Replies: 3
    Last Post: 03-05-2010, 10:59 AM
  2. clunk when i accelerate
    By rick88122 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 12-18-2009, 01:31 PM
  3. throttle response
    By Chevy Young Blood in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 6
    Last Post: 08-19-2009, 09:25 PM
  4. Response Insurance Company
    By Steve in forum Product Reviews
    Replies: 10
    Last Post: 05-26-2009, 01:00 PM
  5. need response asap
    By 4gstarion in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 10-23-2008, 08:52 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •