GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Jr. Engineer jwco5.3's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis, IN
    Posts
    207

    Default Am i running to hot?

    Hey guys. Quick question. my 04 5.3 generally runs at right below the 210 mark. (guessing 200ish). Is this to hot for these engines? I have seen some posts that the engine was designed to run at around 195. I'm about to do an electric fan conversion, which would make it a good time to lower the temperature if needed. Thanks fellas.

  2. #2
    Sr. Apprentice
    Join Date
    Feb 2010
    Location
    Tallmadge, Ohio
    Posts
    30

    Default

    I have a 2000, that always runs just below the 210 mark too. All the other Chevys ive seen, are the same as well.
    2000 Silverado 1500 Z71
    4.8L
    Cat-back dual exhaust
    Corbra 29 CB
    Cold-air Intake


  3. #3

    Default

    Your temp is running pretty average.

    I tried to do the Electric Fan thing but could never get it to keep me under 230.
    Standing in traffic was even worse. But I didn't have a good shroud.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  4. #4

    Default

    I have '05, 5.3 and the temp gauge always reads 210 degress. Hooked up my Diablo Preditor programmer, went to live data section and the temp ran from 192-196 degrees. I think your truck is normal. If you know someone with a scanner/programmer with live data hook it up and drive around to get a accurate reading.

  5. #5
    Jr. Engineer jwco5.3's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis, IN
    Posts
    207

    Default

    Ok good news to me then. Silly as it sounds, I was watching Pinks and they said that 200 degrees is hot. maybe its different for engines making 800 horsepower. Granted, I wouldnt go putting anything two hundred degrees in my mouth, I thought it was pretty average.

  6. #6

    Default

    Yeah, it's pretty different for high-output engines like that. :D
    A lot of guys I know don't even bother running thermostats, or just put a minimal restrictor plate in.
    ...
    ....

  7. #7

    Default

    My '76 Impala is running a 434 stroker motor at about 500HP.

    It will run all day long, in 90 degree weather, at about 210.

    But I have a heavy duty big block radiator from a Chevy WT and run with water wetter.
    Click image for larger version. 

Name:	snc00194.jpg 
Views:	25 
Size:	96.4 KB 
ID:	21094
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  8. #8
    Jr. Engineer jwco5.3's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis, IN
    Posts
    207

    Default

    I can feel how sluggish my truck is when the mechanical fan is running. I'm pretty excited about an electric fan. Going with one from a Taurus. I hear great things about how much air they flow.

  9. #9

    Default

    Be sure to keep us in the loop, pics if you can.

    Could be a cool upgrade.... pun intended.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

Similar Threads

  1. 285/70/17.....anybody running these?
    By DSpivey in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 09-04-2010, 11:30 PM
  2. 05 4x4 running too hot?
    By Bud05 in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 08-12-2010, 11:49 AM
  3. Is anybody running 4.56s with 37s??
    By LivysMan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last Post: 08-09-2010, 06:01 PM
  4. rough running
    By heaviechevie in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 10-16-2008, 05:05 PM
  5. What Oil R U Running?
    By brownbomb in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 12
    Last Post: 10-03-2007, 09:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •