GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default Antifreeze smell under hood but no visable leak

    Ok guys this is what I have; I picked this truck up at an auction a few weeks ago, it has 156,000 miles on it but it runs great. I'm noticing an antifreeze smell from under the hood & I can't seem to find any visable leaks. It does have the red coolant in it, here's the list of stuff I looked at trying to figure this out:

    Starts and warms up fine (stays just under 210), heater works fine too.
    Pass floor dry
    No apparent antifreeze smell in exhaust
    Oil looks normal (oil pressure is at 40 at idle)

    I've read that the 2001 - 2006 5.3's have head problems but considering mine's a 1999 I don't think this is the issue (at least I hope not). Any thoughts?
    2012 Chevy Silverado 1500 LT
    Z71 4X4
    5.3 L
    HD Cooling & Trailering

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Well you may have a faulty Radiator cap, also there is a vent (hence possible bad cap) also if your not using coolant that is where i would start.
    I did have a 2002 that had a clamp fail, and had a slow leak, till i found the broken clamp.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I have had a radiator leak that was small enough that the coolant wasn't dripping but once it was hot it would begin to release steam. That's why i could smell it but not see it. might want to try a SMALL amount of stop leak.
    2002 Chevy 1500 Ex-cab Z71: 5.3L, auto 4, shorties, hi-flow cats, true dual 2.5" straight pipes, AirAid intake, TBS, Platinum plugs, 8.5mm wires, programmer, 3in w/ 33s, also has the composite bed

    2010 GMC 1500 Crew Cab Z71 w/ All Terrain package: 5.3L, auto 6, 2" Zone leveling kit, AirAid Jr. Intake Kit

  4. #4

    Default

    Quote Originally Posted by KWG08VMI View Post
    I have had a radiator leak that was small enough that the coolant wasn't dripping but once it was hot it would begin to release steam. That's why i could smell it but not see it. might want to try a SMALL amount of stop leak.
    I had the same thing happen but mine was the water pump gasket.


    03 Chevy Silverado 1500 ext cab Z-71
    79 AMC Spirit GT
    77 Olds cutlass supreme

  5. #5

    Default

    I agree with murdog94. It's most likely your radiator cap.
    ...
    ....

  6. #6

    Default

    Thanks guys, I'll start with replacing the coolant recovery tank cap as recommended and report back in a few days. Thanks
    2012 Chevy Silverado 1500 LT
    Z71 4X4
    5.3 L
    HD Cooling & Trailering

  7. #7
    Sr. Apprentice
    Join Date
    Feb 2009
    Location
    FT. Wayne, IN
    Posts
    44

    Default

    if thats not the problem check the waterpump... the pump has a small weep hole in the side facing the block.
    2003 Silverado LS 1500 Xcab 5.3 vortec 3.73 rear.
    2000 Artic White Buick Regal GS, 3.4 pulley, 3"dp, 13.81 @ 101 (sold)
    2002 Z28 Camaro, 1sc, a4, slp lid, headers, cb exhaust, 3.73

Similar Threads

  1. Smell antifreeze at starup through a/c vents
    By mwolfe25 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 08-12-2010, 02:19 PM
  2. antifreeze leak?
    By dshewy14 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 03-15-2010, 11:28 AM
  3. 350 antifreeze leakage
    By Aubio in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 02-08-2010, 08:25 PM
  4. Leaking Antifreeze
    By 913projectchevy in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 11-23-2009, 10:44 AM
  5. antifreeze leak
    By Brent0644 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 10-24-2009, 09:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •