GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default trouble with my 4.8....need help

    i finally got my check engine light to stay out and my miss is gone but when i go full throttle it down shifts and goes just like it should till i hit 4000 rpm then nothing happens......it doesnt rev any higher, it doesnt shift it just screams and falls on its face. so all i can do is let off the gas and wait for it to shift, sometimes it happens when im just going up steep hills at 3/4 or so throttle. what can i do to fix this? is it a tranny problem or the ecu?
    03 Silverado 1500
    285/75/16 BFG's
    2 Blaupunkt 10" vW1000 subs in Subthump box
    ProComp Level Lift & 3" rear blocks

  2. #2

    Default

    sounds like the transmission is sliping, you might be loosing a gear.
    2000 single cab short bed 1500 w/ 6.0 vortec maxx swap from a 2006 2500, custom intake, slotted brakes, shorty headers, 8mm wires, electric fan, strait piped, 4.5 inch lift, asp pulleys, true dual through body exhaust, built trans w/ shift kit, custom tune ... 320rwhp

  3. #3
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    god i hope not. its only got 80,000 on it and i sure as hell dont cant afford a new tranny

  4. #4
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    so yeah my trans is poop, it hardly pulls hills that used to race over with no trouble. i talked to a local trans shop and the guy could actually tell me what was going on as soon as i told him what truck i had, so im guessing its kinda a common issue, but he says its th 3-4 input shaft and that its a $700 fix or for $1600 i can get a full rebuild with beefed up 2nd 3rd and 4th gears and pretty nice warranty. Dropping it off monday morning, hoping i get it back b4 xmas

  5. #5
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    What are you going to go with the cheap fix or the rebuild?
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

  6. #6
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    And just so you know i didnt read this thread before the skewd wishes thread!!!! wow sorry dude!
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  7. #7
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    im going for the rebuild, it seems dumb not too especially since i just got the truck and plan on keeping it for 5-10 years


    Quote Originally Posted by murdog94 View Post
    And just so you know i didnt read this thread before the skewd wishes thread!!!! wow sorry dude!
    has anyone else had the skewd wishes thing come true?

  8. #8
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    picked my truck up on on thursday and it didnt even make it home......needed a maf and a cat. needless to say the parts sore gave me a map sensor and the kid i work with couldnt tell em apart and put it on so i went to take it off and return it but it broke in half and fell into the intake mani. 2 hrs and $50 later i got it out. picked up a set of universal cats on my way home today so hopefully this will put an end to my sudden **** streak with my truck.

  9. #9
    Jr. Apprentice
    Join Date
    Dec 2010
    Location
    Brampton, ON Canada
    Posts
    27

    Default

    So what happened that made you aware of the MAF failing. Did you get the tranny rebuilt? This quote is gonna kill you.

    MAF...uses this data to decide upon the operation of the automatic gearbox: several owners have reported gearchange problems and torque converter slip that we discovered was related to a dirty MAF and NOT a problem with the gearbox.

    While this was not a Silverado, I don't know how the GM tranny\torque converter gets its marching orders. You did not say what codes you where getting in your inital thread. Hopefully it was not MAF sensor codes. Any good (profitable) tranny shop is going to tell you, you need a new tranny. Here is hoping you did not get it rebuilt, or if you did, it was really broken.

  10. #10
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    got the tranny rebuilt, and the tech said he couldnt believe i drove it in. i knew the maf was going for a awhile, it didnt matter how much i cleaned it and cleared the code, it came back.....put the cats on on newyears eve and the old ones were really trashed, but its running better than it ever has for me now. i finally hit 5500 rpm yesterday, b4 it died around 4k

Similar Threads

  1. 4WD trouble
    By mrdune in forum GM Powertrain
    Replies: 5
    Last: 10-09-2010, 03:07 PM
  2. Anyone have cat trouble?
    By clgoch187 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 11
    Last: 09-07-2010, 05:33 PM
  3. Trouble with a CAI
    By jjjg_02 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 01-07-2010, 07:13 PM
  4. A/C trouble
    By BajaMark in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 07-06-2008, 09:42 AM
  5. 99 Sub Trouble NEED HELP!!!
    By ljjcsautomotive in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 10
    Last: 02-18-2007, 08:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •