GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 12
  1. #1

    Default 1996 Silverado Spits and Sputters under load?!?!?

    I have a 1996 Chevy Silverado 5.7, Everything is stock, have never had a problem. Lately it has been lugging, spitting and sputtering pretty bad and only getting worse. The best way to acknowledge the problem is to come to a dead stop and stomp on the gas. It used to chirp the tires a little bit, but now it limps up to about 10 mph before it feels like it clears out. My oil pressure is normal, temp doesn't go up and I just replaced the fuel filter trying to troubleshoot a little bit. Need some help! Thought it might be a vacuum line??

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    When was the last time it had an actual full tune up? Also is the Check engine light on? if so you will want to get the codes pulled and go from there as well. With the 5.7L vortec they are particular about having a new cap and rotor yearly for some of us. Also they have a problem with the fuel pressure regulator, and fuel pumps. If the CEL isnt on you will want to get a fuel pressure tester and check the fuel pressure and you will want to have a min of 55PSI of pressure.
    And if you havent done a tune up then do that ASAP since that could be some of the problem as well.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    Thanks, I have not had a full tune up, I actually bought the truck about six months ago with 99,000 on it, I was thinking to have a full tune up, but i would rather try do stuff myself, I do not have good luck with shops. The only reason I haven't brought it in was because it just started doing it recently, never had the problem before so I thought I might be able to pin point it. If it is necessary though, a tune up might be the solution If I cannot fix something myself within the next week, Thanks for the response! P.S. the check engine light came on today when i stopped and stomped on it, it started blinking then just stayed on steady, this goes off in a couple of days, I did it last week as well, full stop and right to the boards, spits and spudders up till about 2000 rpm's then seems like it clears out and my power is solid

  4. #4

    Default

    Get the catalytic converter checked...I have a 2002 Chevrolet Silverado Z71 and I had both changed out w/2 Magna flow high flow converters...Runs better,no more engine clatter @ hard acceleration....

  5. #5

    Default

    My cats are good, i have true duals from the manifolds, two cats and straight pipes, they are fairly new, I have a feeling that if my cat's were a little plugged or had junk in them that the problem would be consistent somewhat, like hammering on it from a low rpm, but it is just under load like i say, i have had distributor problems on other trucks and that problem was not the same as I am having as well. It is driving me nuts though!! Thanks for the input!

  6. #6
    Sr. Apprentice
    Join Date
    Feb 2009
    Location
    FT. Wayne, IN
    Posts
    44

    Default

    if the truck runs rough at lower rpm but clears up when you floor it, usually thats an o2 sensor. Go to your local parts store and get the ses code pulled...
    2003 Silverado LS 1500 Xcab 5.3 vortec 3.73 rear.
    2000 Artic White Buick Regal GS, 3.4 pulley, 3"dp, 13.81 @ 101 (sold)
    2002 Z28 Camaro, 1sc, a4, slp lid, headers, cb exhaust, 3.73

  7. #7

    Default

    I am going to have my codes pulled this week if I cannot figure this out, anyone think it could be vacuum lines creating this problem? I do not hear any air or anything, but i have been told that from a few people??
    If you can't beat em', Scare em'
    Blue 1996 Chevy 1500 z71 5.7 straight pipes

  8. #8

    Default

    I doubt it's the vacuum lines.
    More likely, it's just wear and tear on your tune up parts. O2 sensors usually last around 100K, as well as the original plugs and wires.
    ...
    ....

  9. #9

    Default

    Alright thank you! looks like the Chev is getting a tune up then!

  10. #10

    Default

    Just an update on the chev, it was a combination of old plugs, orignal wires, and cap and rotor!! looks like blue thunder is ready for destruction again!!!!

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Morningtime sputters
    By mvoss2576 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 08-13-2010, 07:38 AM
  2. PLEASE HELP! Egine bogs/sputters with gas only when warm!
    By 02silveradoZ71 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 09-26-2009, 12:04 PM
  3. Truck just sputters then cuts off without warning
    By crane3447 in forum Performance & Fuel
    Replies: 8
    Last: 08-24-2009, 03:18 AM
  4. 1990 burb, sputters off idle
    By myolbug in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 10-06-2008, 02:15 AM
  5. hesitation/surge under load 03 Silverado
    By jackoue in forum GM Powertrain
    Replies: 2
    Last: 01-14-2008, 05:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •