GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Blower Fan Speed Messed Up!

    I recently purchased a 2003 Silverado and have noticed that the blower speed at the 1 setting is faster that the 2 and 3 setting, 4 and 5 are fine. It's almost like the wires have been crossed as the 3 setting has the fan speed one would normally expect for 1 and the 1 setting has the fan speed one would expect for 3. Anyone else had this problem.

  2. #2
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    MAY be your problem.

    Have a look here.

    Different year but, like I said, might be your issue as well.
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  3. #3

    Default

    These chevy's are known for the blower motor resistor and wire harness going bag and to replace the wire harness it is required to cut all the wires and use butt connectors to connect the new harness to the wires that were cut off. If you take the glovebox out you will have access to the wires-I would make sure that if you see butt connectors there that all the wires are connected correctly.

  4. #4

    Default

    I recently had a similar problem. I have a 2002 Silverado and what I thought to be a control switch problem, ended up being a burned up blower motor resistor harness. The dealership wanted to bend me over for close to $100... I did some looking around on my own and found one that was only $33! Not only was it way cheaper, but it was color coded to match my original harness. The one the dealership mechanic showed me only had black and white wires and seemed to only have one size wire gauge. I'm no mechanic or electrician, but it seems to make good sense that you would want to match the wire gauges. The one I found did and it came with butt connectors. I found and purchased it at http://www.buywiring.com/7-wire_blow...co_pt2195.html

    My heat/ac works perfect now and I'd recommend that anyone with a similar problem check their blower motor resistor harness along with the climate control switch, resistor, and blower motor (all of which were suggested by the dealership mechanic I went to). Hope this helps!

Similar Threads

  1. 89 brake/turn signals messed up
    By finkenator9 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 08-20-2010, 04:38 PM
  2. 01 Silv with erratic blower speed???
    By aftershock00 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 08-04-2009, 10:07 PM
  3. What Part of my Tranny is Messed Up?
    By Crawdaddy in forum GM Powertrain
    Replies: 24
    Last Post: 05-19-2008, 07:46 AM
  4. Website Format Messed up
    By Steve in forum Announcements & Feedback
    Replies: 4
    Last Post: 03-26-2008, 02:35 PM
  5. Desperate for help!!! Katrina messed up my Tahoe!
    By cheffernan in forum The Coffee Shop ~ Chit Chat
    Replies: 5
    Last Post: 09-02-2005, 09:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •