GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Default cant figure out the problem with my 87 :(

    alright so i have a 87 chevy 1/2 ton truck with a tbi 350 but the motor is not the original motor it has a older motor in it that somebody swapped all the tbi stuff back onto now when i go to start it when you turn the key over the fuel pump in the tank is constantly running never shuts off then when you go to crank it it will sit and crank forever then you turn the key off and turn it back on then it will crank and crank and crank then it will fire right up anyone know what the deal is??? it also has two tanks that apparnetly the switch or the solenoid tht is inbetween the tanks went out and someone jerry rigged the thing to get it to only use the one tank instead of fixing it right looks like the cut a few lines and idk its just a mess if anyone has has some expierence with this problem i could use all the input i can get! also has a new fuel filter on it from what i can tell

    this is a picture of the solenoid that connects the two tanks dont know if this is how it is suppose to look from the factory so if anyone else has some pictures of how it should look that would be awesome!


    ---------- Post added at 09:55 PM ---------- Previous post was at 08:09 PM ----------

    i just figured out the fuel problem with my truck there is a fuse in the fuse block for a ecm2 and there was no fuse in there so i put a fuse in and two cranks she fired right up!!!! i tried it 4 times just to make sure and sure enough thats the problem so now the problem is that when the fuse is in there when you shut the key off the truck stays running but if you pull the fuse it shuts off so the only way i can see to fix it is to run a kill switch to this fuse
    this is the fuse that was missing
    NO truck at this time :( currently running a lifted 01 jeep wrangler for now....till next week :)

  2. #2

    Default

    anythoughts???

  3. #3
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Probably not what you wanted to hear, but the fuel switching valve is expensive, & even if you replaced it, the dash switch might also be bad & it is just more $$ so most everybody always just bypassed the valve & ran both tanks together. Besides saving money it also gives you the benefit of drawing on both tanks together so the fuel in the alternate tank never goes stale.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  4. #4

    Default

    i foiund that the solenoid on lmc is only 99 dollars and thew switch is only a couple bucks

  5. #5
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    ha ha, ok, the price has gone up 100% since my dad decided not to replace his. If I remember right it was around $50. back then.

  6. #6

    Default

    dang lol well that still doesnt solve my problem of my truck not shutting off when i turn the key off with that fuse in :(

  7. #7
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Sorry, I have no clue what the electrical part of your problem could be. Since this engine was swapped before you got it, it is most likely something that was done to make this older engine work with the newer wireing harness. Can you contact the owner that you bought it from & ask him?

  8. #8

    Default

    I think the ecmb fuse goes to the fuel pump, so my guess would be the fuel pump not shutting off. maybe a bad relay somewhere? start testing wires for continuity and double check connections. Only things I can think of, haven't touched a tbi in a couple years.

  9. #9

    Default

    well i'm guessing the fuse was out, because they had a wiring problem causing the truck to not shut off. This type of problem just takes some time and wire tracing, but you should be able to do it. On that year, you should have an ignition switch somewhere on the steering column, with a hot all the time going to it, and a switched off the key coming out. usually red/yellow wires, one should be hot, one switched (don't remember right off which is which). if you've got juice all the time on all wires with key on or off, then you need a new ignition switch, and that's your problem. if the switch is working properly, then somewhere in their transplant, they hooked the switched ignition feed to battery +12v. Do some tracing with a good multimeter, and see what's hot and what's not with key on and off.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

  10. #10

    Default

    now see shouldnt these year trucks shouldnt you be able to turn the key backwards to get the radio to come on? cause that tumbler will not turn back what so ever idk if this has anything to do with it

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. How to figure out my Stock Gear Ratio?
    By fx2offroad in forum Lifted & Offroad Suspension
    Replies: 3
    Last: 06-21-2010, 11:29 PM
  2. New and trying to figure it all out??
    By RunningOnEmpty in forum Member Introductions
    Replies: 10
    Last: 11-29-2009, 01:37 PM
  3. Help! Mechanics can't figure out AC's odd behavior
    By joelbra in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 09-29-2009, 10:40 AM
  4. Cannot figure out how to load torsion bars!
    By ippielb in forum Lifted & Offroad Suspension
    Replies: 12
    Last: 09-07-2009, 08:47 AM
  5. No spark, and I can't figure out why. 87 Suburban 3/4t 4wd, 350
    By rykoala in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 02-11-2007, 08:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •