GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Finally installed my setup. Clicking sound from speakers? bass tuning? Suggestions?

    I have a feeling its just an issue of settings on the amp hopefully. But I was wondering how to tune my subs. I have two 10" kickers in the back powered by a 500W Alpine amp. Bass comes from them, but I feel like the bass should be louder than it is. I have my amps settings (gain, LP, and EQ) All on the middle setting, and Gain on 3/4. I feel like people's cars ive been in with only one 10" made louder bass than my two 10"'s

    And I noticed one 'tiny' problem today though. When the radio was on, I heard a clicking sound when music was playing coming from the speakers. When I paused the cd, the clicking sound still clicked. I didn't have long to play with it, but I hope its nothing serious.

    Other than the clicking problem and bass tuning, thats it! Im glad its all finished and hope I can fix these two quirks soon.

    Any suggestions?

    Setup:
    Amp: Alpine MRP-M500
    Per channel output into 4 ohms: <1% THD+N, 14.4V, 300Wx1
    Per channel output into 2 ohms: <1% THD+N, 14.4V, 500Wx1
    Input Inpedance: RCA IN: 20k ohms | SP IN: 40K ohms
    Frequency Response: 20-200Hz

    Sub (2): Kicker TC10--C
    Normal Impedance: 4ohm
    Sensitivity: 93.8dB
    Power Handling Watts, Peak: 300 (150) RMS

    Receiver: JVC KD-HDR60
    Last edited by crewxp; 10-26-2010 at 01:33 PM.

  2. #2
    Jr. Apprentice
    Join Date
    Oct 2010
    Location
    Mckinney, Tx.
    Posts
    20

    Default

    I would suggest checking your RCA cable. Sounds like your'e picking up some sort interference, due to it being cheaply made or it is being crushed somewhere. RCA cables are one thing that should not be skimped on as far as wiring goes. It may cost you 100 instead of 20 bucks or whatever but will be worth it in the long run.

  3. #3

    Default

    x2 could be a bad ground somewhere ... possibly engine noise.

    Here is a link that might help you.

    http://www.crutchfield.com/learn/blo...-properly.aspx

    http://www.crutchfield.com/App/Learn...egory.aspx?c=3

Similar Threads

  1. DDM Tuning HID Kit Installed
    By Coolwheels05 in forum Lighting Discussion
    Replies: 4
    Last: 12-18-2009, 04:37 AM
  2. whats your best sound system setup?
    By lowsilverado in forum Chevy Truck Accessories
    Replies: 7
    Last: 10-07-2009, 11:05 PM
  3. Any suggestions for a single cab wanting bass?
    By b_ehrm in forum Audio, Video & Gadget Tech
    Replies: 5
    Last: 03-19-2009, 06:25 AM
  4. Need brake setup suggestions
    By browenb in forum Lifted & Offroad Suspension
    Replies: 6
    Last: 03-04-2009, 09:06 PM
  5. Clicking sound under 2000 silverado
    By mikey82 in forum GM Powertrain
    Replies: 6
    Last: 03-15-2008, 04:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •