GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Transmission Issues

    Folks:

    Need some advice from the people much smarter than me when it comes to vehicles.

    We have a 2004 Suburban with 122K miles on it. This has been a fantastic vehicle, one I'm hoping to hold onto for much longer.

    This evening my wife was heading to the grocery store when just a few blocks from my house the suburban shifted into something like neutral. She moved it into multiple drive slots with no luck. She finally shut the engine down and started it back up and with no luck, but when she put it in reverse, it kicked into gear and she was able to put it in drive and get it home.

    I then took a spin and the same thing happened to me. This time I shut the engine off and it would not go into gear immediately. After sitting for a couple of minutes I then got it to engage and get it home.

    Transmission fluid is fine (just had the oil, etc. changed yesterday).

    Have I lost my transmission or is it something else?

    any help is appreciated!

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Hi Casey, Welcome to the GM Truck Club. If you just had the trans fluid & filter changed yesterday & now today you're having this problem, I think your filter is sucking air. This could be due to multiple reasons, but you need to either take it back to the shop or r&i the trans pan & look at why it's sucking air at the filter.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3

    Default

    I think I misspoke...we didn't have the transmission fluid changed, just checked during the normal oil change.

Similar Threads

  1. Transmission issues 82 elcomino
    By mralers86 in forum GM Powertrain
    Replies: 9
    Last Post: 05-14-2010, 08:11 AM
  2. More transmission issues
    By rustyk2 in forum GM Powertrain
    Replies: 24
    Last Post: 05-08-2010, 02:37 PM
  3. Transmission Issues
    By allwheelspin in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 11-15-2009, 12:57 AM
  4. Replies: 0
    Last Post: 07-15-2009, 10:20 PM
  5. Transmission or other Drive line issues???
    By sgodder in forum GM Powertrain
    Replies: 5
    Last Post: 12-11-2008, 09:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •