GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Default installed overhead DVD player, now the truck is "slow" to start. Help?

    Ok, I had an overhead DVD player installed in my 2007 NBS silverado crew cab yesterday. Since that time, the truck has been slow to start, meaning that when I turn the ignition, there is a 2-3 second delay before the truck actually cranks. I am getting no codes, lights, or security issues. It starts with the remote start with no problem. It doesn't appear to be anything serious, other than the delayed ignition. Is this a major problem, something that I need to be concerned about?

    Any help is appreciated. Thanks!

    2007 Silverado LT Z71 4x4 Crew Cab
    Dark Metallic Blue

    Mods to come, just purchased on 10/31/09

    Go Pack Go!

  2. #2

    Default

    Thats strange. I've installed a lot of car audio but have never had a problem like that. Where did you tap your power wire into?

    2006 Duramax LBZ
    Edge Evo
    4'' Diamond eye to 6'' tip
    16'' ion alloy, 33'' fierce attitudes
    Lots of work left to do!

  3. #3

    Default

    I spoke with the installer, and he says that he drew power through the dome light. I did some research and it sounds like it may have something to do with tapping into the ignition circuit? What I find interesting is that I found a DTC online, P1682, for the delayed or extended motor cranking, but I am getting no codes on the truck...

  4. #4

    Default

    my best guess is that the overhead dvd player is drawing power even in the off position, resulting in draining the battery which is causing a delayed start. My reasoning for the remote start is its not powering up all the systems of the truck immeditaly (hvac, radio etc.) that it cranks and starts then turns everything on since the cranking is being controlled 100% by the computer. This is my best guess, I would look and see how other dvd players were installed and where they pulled power from., and if there is a way to make sure the entertainment system doesn't draw any power when not in use.

  5. #5

    Default

    I have noticed the voltmeter running in different positions, rather than "top dead center" on the gauge.

  6. #6

    Default

    You're heading in the right direction there with the DTC delayed crank. I suspect it's where the installer caught switched ( ignition ) power for the monitor. I have experienced this on a few GM products. Have the installer move the switched power supply wire to a different source. I usually add my own fuse holder and go to an empty spade on the distribution block to the left of the brake pedal. hope this helps.


    Patrick

  7. #7

    Default

    Quote Originally Posted by Lunatic Fringe View Post
    You're heading in the right direction there with the DTC delayed crank. I suspect it's where the installer caught switched ( ignition ) power for the monitor. I have experienced this on a few GM products. Have the installer move the switched power supply wire to a different source. I usually add my own fuse holder and go to an empty spade on the distribution block to the left of the brake pedal. hope this helps.


    Patrick
    I agree one hundred percent. I like using my own fuse holder because it is reliable and safe. It does sound like your drawing to much power. When my amp is turned up i can watch my needle on my volt gauge move because the alternator is trying to charge the battery. I don't think that would cause a delay in your starting though. You would just have less starting power. Somehow the power has been tapped into the ignition circuit and has caused a interruption of some kind in the circuit.

  8. #8

    Default

    Quote Originally Posted by hutch_pt View Post
    I have noticed the voltmeter running in different positions, rather than "top dead center" on the gauge.
    With the NBS Silverados, they have a high-tech charging system. They will change quite a bit as the battery needs to be charged and other cirumstances. But, it should beshowing around 14 everytime it has a hard time cranking because it will be running power to everything and charging the battery. If you crank anf it sits around 12 or then your battery probably isn't being drained .. if you got a multimeter check your battery voltage before and after crank.... another thing maybe check the battery connections and ensure tight fit??? maybe installer unhooked battery and didn't tighten them down yet...???

  9. #9

    Default

    Whats happening here is the ignition circut is sensing the additional resistance of the aftermarket wiring/device. the body computer is analysing this resistance and causing the delayed crank condition. I recently repaired an Impala with exact same issue, the customer had installed his own CB radio, and caught power at the ignition harness, ( like our trucks ) it's only fused at 10 amps. the additional resistance on the ignition caused the body computer to engage the starter later into the cycle. Moving the CB's wiring to the car's accessory circut instead remedied this issue. I do not recomend tapping into a silverado accessory circut however, it is similarly fused, your going to want a heavier current source for a tv, espically if a dvd player is onboard with it. Check out the power distribution center, by the brake, in most cases there is a empty 6 or 8 pin socket there, I dont recall the exact pin, but one of them will test as an accessory.

    Patrick

  10. #10

    Default

    There's only one variable involved between now and before, the installation of the dvd unit. Try disconnecting the dvd unit for a couple days and see if it takes longer to crank. It will probably take at least one drive around town to get it back to "normal" because the battery probably needs to get charged back up. If that fixes it, the dvd is pulling power even when turned off and is drawing the battery down enough to cause the starter to turn slower resulting in longer startups.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 277K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Stock "P" rims safe with "LT" tire pressure?
    By xycarp in forum Wheels & Tires
    Replies: 2
    Last: 05-31-2010, 09:38 AM
  2. AAACK! - '97 Burb, 5.7L suddenly "No Start"
    By Applegeek in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 20
    Last: 02-09-2009, 10:55 AM
  3. Replies: 0
    Last: 06-21-2008, 12:30 PM
  4. Replies: 0
    Last: 07-24-2007, 12:30 PM
  5. "Monster Mash" Singer Bobby "Boris" Pickett Dies At 69
    By Cableguy in forum The Coffee Shop ~ Chit Chat
    Replies: 0
    Last: 04-27-2007, 10:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •