GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 2001 Silverado 1500 trouble code P0118 and P0453 and temp guage doesnt work

    I have a 01 silverado 1500 with a 4.8L having some trouble.
    I get codes P0118 and P0453, when I clear codes they come right back on.
    changed fuel pump and ECT sensor recently after temp guage quit working.
    sometimes when driving on rough roads or stopping abruptly the engine will quit but then starts up and runs ok.
    any ideas
    Thanks
    Jon

  2. #2

    Default

    Quote Originally Posted by N5856Z View Post
    I have a 01 silverado 1500 with a 4.8L having some trouble.
    I get codes P0118 and P0453, when I clear codes they come right back on.
    changed fuel pump and ECT sensor recently after temp guage quit working.
    sometimes when driving on rough roads or stopping abruptly the engine will quit but then starts up and runs ok.
    any ideas
    Thanks
    Jon
    For the Code...P0118......may mean that one or more of the following has happened:
    • A bad connection at the sensor
    • An open in the ground circuit between the ECT sensor and the PCM
    • A short in the voltage feed between the sensor and the PCM
    • A bad PCM (less likely)
    • A bad temperature sensor (shorted internally)

    For the Code...P0453.....may mean that one or more of the following has happened:
    • Open on FTP sensor signal wire
    • Short to voltage on FTP sensor signal wire
    • Bad FTP sensor
    • Abnormally high pressure in fuel tank due to blockage in EVAP purge hoses or overfilled tank
    • Loose/damaged FTP sensor connector
    • Loss of ground to the sensor

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    ok I will look into that. just thought I share some more info.
    I pulled the connector to the ECT and checked voltage with key on and I get 12 volts, I checked the other wire that should go to ground or signal return to the PCM I get nothing. I'm thinking that the ground wire or return wire is open, would need to pull the connector off the PCM and check continuity on those wires. not sure where the PCM is located the haynes manual isnt real clear on where the PCM is located.
    also if I clear the codes the P0118 comes right back on after 30 seconds.
    I cleared the codes this morning before I went to work, the MIL light came on before I could back down the driveway. Tonite leaving work I cleared the codes and the MIL light didnt come on at all, but the P0118 code is there now. I believe the P0453 code is what is turning on the MIL light.

  4. #4

    Default

    I traced some wires tonite on the ECT circuit and found the connector at the ECT is intermittent. I found I have continuity from the ECT plug(yellow wire) to pin 74 on blue connector of PCM, but not sure what pin the ground (gray or tan wire) goes to on the PCM. where can I get a new connector for the ECT at?

  5. #5

    Default

    ok I solved my ECT code P0118, ended up being a bad connector at the ECT sensor.
    I still get the P0453 code FTP sensor.
    I looked at my manual at it says the FTP sensor is in the fuel tank pump module. I replaced that pump about a month or so ago, and really dont feel like pulling the bed off to get to the fuel pump again. anyone have the wiring diagram for the FTP sensor and what pins it goes to on the PCM.

Similar Threads

  1. temp. guage fluxuating
    By tcook18 in forum GM Powertrain
    Replies: 2
    Last: 01-13-2010, 12:46 PM
  2. Tranny Temp Guage
    By CarpenterGuy in forum GM Powertrain
    Replies: 7
    Last: 11-19-2009, 10:00 PM
  3. 05 Chevy Silverado Oil temp gauge doesnt work right.
    By beerguy25 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 03-10-2009, 10:47 PM
  4. Temp Guage Not Working
    By BIGFOOT in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 12-31-2008, 12:49 PM
  5. temp guage.
    By thebandit110 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 12-19-2007, 04:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •