GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 1991.GMC burb 4x4 tbi 350 timing issues

    Hello to all of you here on chevy talk i googled my problem and vola here i am . Can anyone please help me im having a pinging problem with my burb 350 tbi 1991 i bought this truck two years ago from the original owner its a 91 but only has 118xxx miles i currently use it for a plow truck my problem started two days ago it all of a sudden started pinging bad im mechanicly inclined but not much with computer cars or truck when i bought the truck i tuned it up myself cap wires rotor plugs was running just fine until two days ago .CAN ANYBODY HELP ME PLEASE to figure out what happend thank you in advance shawns gmc...

  2. #2
    Master Mechanic BurbanMan's Avatar
    Join Date
    Jul 2013
    Location
    Dolores, CO
    Posts
    796

    Default

    Does your dizzy have a vacuum advance? Initial timing Iirc is 0*
    Chuckie!!!


  3. Thanks Shawns gmc thanked for this post
  4. #3

    Default timing issue ?

    Quote Originally Posted by BurbanMan View Post
    Does your dizzy have a vacuum advance? Initial timing Iirc is 0*
    No vacume advance . What would make it all of a sudden start pinging like it's hot but it isn't hot but it

  5. #4
    Master Mechanic BurbanMan's Avatar
    Join Date
    Jul 2013
    Location
    Dolores, CO
    Posts
    796

    Default

    It may also be time for a timing chain. Could be bad fuel. There's a lot of things to factor in
    Chuckie!!!


  6. #5

    Default

    I've been having similar issues with my 1991 Suburban. When I first start the truck up, it wants to die and backfires, but once it warms up for a minute, it runs perfectly. Are those symptoms to yours? My timing is somewhere around 3* BTDC but should be at 0*. I'm going to re-time it when I get a chance to make sure that isn't the issue.

    EDIT: Also moved this to Powertrain since there's really no introduction.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 265K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

  7. Thanks Shawns gmc thanked for this post
  8. #6

    Default

    today i change the temp pressure switch and when i started it up it started hard i had to hold the gas pedal half way down . I thought it was running better but when i took it for a ride it started pinging again with only 118000 miles would it/could it need a chain i always got alot more miles out of a timming chain Any help would be forever gr8ful if anyone has the time please E-mail me THANKS in advance Shawn shawnhammes45@gmail.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •