GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default 2000 silverado 4x4 transmission problem?

    My 2000 silverado 1500 4x4 with 5.3 has a wierd problem that I think is transmission related. When I go from park or reverse to drive most of the time there is a noticeable lag like the tranny is being lazy going into drive. If i give it more gas it sometimes will bang into gear hard so i just easily feather it. Once it goes in drive it is fine and i can drive all over with no problems. It does this most but not every single time. Could the gear selector on the trans be acting up or do I need a rebuild? The truck does have 216,000 miles. thanks

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Well when was the last time the tranny was serviced? if its been a while i would start there. then get it scanned for codes at your local tranny shop...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    I just bought this truck last week with known problem. No trouble codes and fluid looks good, just figured it might be an easy fix. May try changing the filter and fluid.

  4. #4

    Default

    Changed fluid and filter still does same thing.

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Now not trying to be a jerk here but who checked for trouble codes?? since a tranny code cannot be read with most handheld scanners, and will not always illuminate the CEL... Also there are a few threads on here that talk about the valve body as well as line pressure etc..

  6. #6

    Default

    I used my mechanic friends snap-on analyzer and there were no trouble or history codes. Sometimes the tranny is fine and sometimes it acts up. Was wondering what the valve body and line pressure problems were and there symptoms?

  7. #7
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Low line pressure can cause this. There are also specific pressures for each gear position selected. See if your friend has a 0 - 200 psi guage that you can plug into your port. You can find the acceptable pressures for each gear position online. Don't use a guage that has less than 175 psi max reading or it will probably bend the needle around the pin lol.. Don't ask how I know that last part...
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  8. #8

    Default

    If you service the transmission try putting in some Lucas trans fix. It removes old varnish that builds up in the trans and makes some of the valves in the valve body stick. I've talked with a few people that have tried it and they say it worked.

  9. #9
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by silveradotrailblazer View Post
    If you service the transmission try putting in some Lucas trans fix. It removes old varnish that builds up in the trans and makes some of the valves in the valve body stick. I've talked with a few people that have tried it and they say it worked.
    X2 here Ive used it with great results... on my 313ish K Miles S-10 Blazer and it made a HUGE DIFFERENCE!

Similar Threads

  1. 2000 Silverado transmission issues
    By Sooner22 in forum GM Powertrain
    Replies: 6
    Last: 11-03-2013, 10:19 PM
  2. Transmission Problem '09 Silverado
    By lfb57 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last: 09-30-2010, 12:06 PM
  3. 2000 Tahoe Transmission
    By surfacedr in forum GM Powertrain
    Replies: 1
    Last: 06-01-2010, 10:15 AM
  4. 2000 Tahoe Transmission
    By surfacedr in forum Member Introductions
    Replies: 4
    Last: 05-30-2010, 02:53 PM
  5. 2000 Silverado Fog/Headlight Problem
    By DaveyBoyo in forum Audio, Video & Gadget Tech
    Replies: 9
    Last: 02-05-2009, 02:52 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •