GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 1996 GMC Suburban SLE Radio/Electrical problems

    hi everyone - i'm new here and i have a strange problem that i have scoured the web to fix. i have had no luck so far.

    i have the stock 8 speaker system with the amplifier under the seat. i do not have onstar or any kind of security system other than the stock keyless entry.

    so here we go:
    sometimes the radio works perfectly and sounds great but other times the volume will be blaring and the only way to get it to go down is to turn it up. when you do this it slowly goes down and when you turn it down, it slowly goes up...
    sometimes even when the radio volume is functioning, we'll lose volume in the rear speakers except for a scratch here and there (i think this may be a separate issue)
    at times when it's acting up, we can turn on the air conditioner fan and it will immediately start working perfectly.
    the amp seems to be working fine at this point.
    i don't know if it's related but the airbag light comes on intermittently as well.

    anyone run into this or have any thoughts? thanks so much for any help!

  2. #2
    Sr. Apprentice Z28Johnny's Avatar
    Join Date
    May 2009
    Location
    Salt Lake City
    Posts
    72

    Default

    that is a really buggy issue. I had a 96 and the first thing I did was install a full system with new wiring from the 5 channel amp to each speaker. I think this is the best way for stereos. Intermittent electrical problems like what you have can be difficult to diagnose. I would get a scanner hooked up and see if it is throwing any codes.

    John
    2001 Yukon XL 2500
    8.1 Liter (badged on rear) w/K&N filter
    20" wheels with 305/50/20 Nitto Terra Grapplers
    Alpine deck (w/ipod), Polk speakers, Kicker 700.5 amp, Rockford P3 12" sub, and video screen
    LED tail lights
    Predator tuner
    new carpet and seat covers

  3. #3
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Welcome to the Club!!!


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  4. #4

    Default

    thanks for the welcome. i did hook her up and there were no codes...:(

    so did replacing the entire system help solve the problem?

  5. #5

    Default

    Well thank GOD its a normal problem and I am NOT crazy (well that will still be debatable in the house).
    My burban is doing the same thing. So out with the old and in with new. I don't know if my husband is going to
    like this idea, then again he is not a big fan of chasing electrical problems.

Similar Threads

  1. 1996 K1500 Electrical Issues
    By SilveradoBrett in forum GM Electrical Tech
    Replies: 6
    Last Post: 11-28-2011, 01:44 AM
  2. electrical problems need help
    By silver89aldo in forum Audio, Video & Gadget Tech
    Replies: 8
    Last Post: 08-01-2009, 04:43 PM
  3. 1996 Suburban A Few Problems
    By meenkeene518 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 08-24-2008, 12:39 AM
  4. 1996 Suburban AC Problems
    By bigbob94 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 05-15-2008, 07:26 PM
  5. electrical problems? [Expired Topic]
    By romanhood in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 12-11-2006, 08:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •