GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Jr. Apprentice Rem870Tactical's Avatar
    Join Date
    Oct 2010
    Location
    Crown Town, SoCal.
    Posts
    12

    Default Problem with Spedometer, and oil gauge.

    My oil gauge will just randomly go all the way low, or all the way high, or jjust does what ever it wants, and my Spedometer will just stop working too(happened only like a few times). so i need to know whats wrong. it just got all new fluids for everything, and even a brand new transmission which isnt even 3 months old yet. with little mile on it too.
    -2002 Ford F-250, Powerstoke 7.3L Diesel, Crew Cab, Short Bed, 4x4.
    -2004 Chevrolet Suburban LT, V8, 2WD Only.
    -2005 Chevrolet Silverado 1500 LS, V8 4.8L, 2WD Only, Extended Cab, Standard Bed.
    -2005 Fleetwood Gearbox FS2600.
    -2006 Suzuki LT-R450, White, Suzuki Nerfs, 20 on 8's Holeshot in rear, 22's up front Hoelshot HD, Yoshimiura RS-5 Full Exhaust System, and a Yoshimiura Cherry Bomb, Pro Armor Kill Switch, Pro Armor Dominator bumper. Moose Parking Brake block off(Red).

  2. #2

    Default

    Quote Originally Posted by Rem870Tactical View Post
    My oil gauge will just randomly go all the way low, or all the way high, or jjust does what ever it wants, and my Spedometer will just stop working too(happened only like a few times). so i need to know whats wrong. it just got all new fluids for everything, and even a brand new transmission which isnt even 3 months old yet. with little mile on it too.
    The problem with your gauges is most likely is the Stepper Motor's for those 2 gauges......need to be Replaced......also which Vehicle is having the problems with the gauges and how many Miles are on the Vehicle??

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3
    Jr. Apprentice Rem870Tactical's Avatar
    Join Date
    Oct 2010
    Location
    Crown Town, SoCal.
    Posts
    12

    Default

    Quote Originally Posted by 99'HEARTBEAT View Post
    The problem with your gauges is most likely is the Stepper Motor's for those 2 gauges......need to be Replaced......also which Vehicle is having the problems with the gauges and how many Miles are on the Vehicle??
    its my 05 silverado(see description in sig) but it has around 140k miles(prolly a little more), it runs like a champ and i have found no probs other than little dinks, and scratches, and my brakes are brand new and squeaking(i figure dust).
    -2002 Ford F-250, Powerstoke 7.3L Diesel, Crew Cab, Short Bed, 4x4.
    -2004 Chevrolet Suburban LT, V8, 2WD Only.
    -2005 Chevrolet Silverado 1500 LS, V8 4.8L, 2WD Only, Extended Cab, Standard Bed.
    -2005 Fleetwood Gearbox FS2600.
    -2006 Suzuki LT-R450, White, Suzuki Nerfs, 20 on 8's Holeshot in rear, 22's up front Hoelshot HD, Yoshimiura RS-5 Full Exhaust System, and a Yoshimiura Cherry Bomb, Pro Armor Kill Switch, Pro Armor Dominator bumper. Moose Parking Brake block off(Red).

  4. #4

    Default

    Quote Originally Posted by Rem870Tactical View Post
    its my 05 silverado(see description in sig) but it has around 140k miles(prolly a little more), it runs like a champ and i have found no probs other than little dinks, and scratches, and my brakes are brand new and squeaking(i figure dust).
    G.M......has a Coverage adjustment on the Dash Cluster's....In which they will replace the dash cluster's......Sadly with the mileage you have your Silverado....the coverage won't help.....Below is a link a that goes into detail about G.M. Coverage Adjustment

    G.M. Link,
    http://www.gmspeedometerrecall.com/


    On the Stepper motor's.....those are going to need to be replace.....There are shop that do repair's on the Dash cluster's.....here on this site and/or E-bay there are few shops that can also help.

    Picture of where Stepper motor is Located,


    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  5. #5

    Default

    I was riding home last night from work and sure enough, the speedometer started reading 20+MPH less than actual. This morning's ride back in, the speedometer was fine. I'm sure I'll be replacing the stepper motor shortly. I have 92K miles on the truck so I'm out of the recall window.
    2004 Chevy Silverado 1500 w/ext cab and stepside bed.

Similar Threads

  1. Gauge cluster problem help!!
    By pdizzle2002 in forum GM Electrical Tech
    Replies: 3
    Last Post: 05-07-2011, 11:12 PM
  2. tenp gauge problem
    By Giz in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-27-2009, 08:52 AM
  3. 05 Silverado Gauge problem
    By reddedsilvy05 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 04-08-2009, 01:19 AM
  4. Fuel Gauge Problem
    By MD4x4 Fireman in forum The Coffee Shop ~ Chit Chat
    Replies: 0
    Last Post: 10-25-2007, 03:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •