GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1
    Jr. Apprentice
    Join Date
    Jul 2010
    Location
    San Antonio, TX
    Posts
    23
    Blog Entries
    2

    Default Has anybody ever replaced an oil pump on 454

    I have a 1995 K2500 suburban with the 454. I am getting low oil pressure after it has been running when I come to a stop light and stop. I have replaced the oil pressure sensor checked the voltage on the harness, the next step i think is to replace the oil pump. I have done this on a 85 Scottsdale that was a two wheel drive but, I was talking to a guy at work, and he said that I would have to undo the motor mounts, and jack up the motor. I don't have the truck with me so I cant look at it right now but I thought I would just have to drop the skid plate, and the oil pan relatively easy. Has anybody ever done this how much of a head ache should I expect?

    Thanks

    Tabor

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Yes I've done an oil pump on a 454 but it was a 2wd. The reason the mech is telling you that you may need to pull the motor mount bolts, is so you can jack the engine up a little bit so you can get the oil pan off. There usually is not quite enough clearance to slide the pan out. As far as difficulty factor, it's pretty easy. You should have no trouble if you have even "a minimum of experience."
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


Similar Threads

  1. Windshield Washer Pump not working (not the pump)
    By vdubn in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 11-20-2010, 09:39 PM
  2. Replaced Radiator, but... HELP! Lol..
    By Al Stefanelli in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 03-05-2010, 09:18 PM
  3. replaced knock sensors
    By Peckens in forum GM Powertrain
    Replies: 4
    Last: 09-28-2009, 10:08 AM
  4. Steering shaft replaced twice?
    By jbeall in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 02-25-2009, 08:51 PM
  5. Has any one replaced the projector headlights??
    By memphisrep in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last: 11-21-2008, 04:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •