GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Some issues with shifting

    Alright so I have a 2000 suburban 5.3 and recently I noticed that my transmission felt like it was delaying with shifting. Rpms went higher than normal and It didn't shift until about 90mph into 3rd gear(I'm assuming) I figured it was my superchips tune messing up so I pulled the tune off and its still doing the same thing. I'm not sure what the issue can be, never had issues with shifting. There's 118k on motor also idk if this will help but when I got the truck I hooked up a snap on scanner to it and it said shift sensor B if I remember correctly any help at all would be great...thanks guys
    Nothin like a liftd truck goin muddn

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    If that is the code that you were given you will want to google the code and troubleshoot for that code since trannies can be rather complicated rather than a staight forward repair.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    Yeah. I have to get it back onto a snap on scanner, and re check it. Does anyone else have any input I'm really worried bout the truck due to lack of funds and winter is almost here
    Nothin like a liftd truck goin muddn

  4. #4

    Default

    Alright so in the mass confusion of me trying to figure out other issues i forgot bout the trans, upon investihations its been determined that the problem is shift sensor b malfunction, no 4th gear so does neone know how hard it is to fix this issue
    Nothin like a liftd truck goin muddn

Similar Threads

  1. 87 suburban shifting issues?
    By socal77k5 in forum GM Powertrain
    Replies: 1
    Last Post: 06-12-2010, 06:05 PM
  2. Transmission(not shifting)
    By busytwinmom in forum GM Powertrain
    Replies: 4
    Last Post: 11-25-2009, 06:42 PM
  3. k2500 not shifting - electrical issues?
    By carl s. in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 05-24-2009, 09:53 PM
  4. Shifting into reverse
    By adam4lsu in forum GM Powertrain
    Replies: 0
    Last Post: 04-24-2009, 05:39 PM
  5. not shifting out of first
    By bbk28 in forum GM Powertrain
    Replies: 4
    Last Post: 01-02-2009, 06:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •