GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Battery Not Charging

    2003 Chevy Suburban with a display of "Battery Not Charging". Have installed a new battery, and got alternator tested which showed good?????? Any ideas...

  2. #2

    Default

    Get a multimeter and check the voltage at the battery when engine is running. Should read 13-14 volts. If not bad alternator, if the alternator isn't working then battery voltage should slowly drop and truck will eventually give out once voltage gets too low.

    If thats good maybe a bad regulator on the alternator. Check all your connections as well.

    More details might help as well.

  3. #3

    Default

    By reading more posts on this forum about this same issue, I found out that it is better to take the truck up to Auto Zone and get the alternator tested while on the truck. Because previously I had it out of the suburban and it tested good, this time I took the suburban up there and got it tested. This time it tested bad. Got a new alternator and got my battery charged there. It is working like a champ now. Thanks for the info, and yes the battery voltage was dropping on the battery while it was getting tested.

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    glad you got everything fixed, and for anyone else it is always better to have them test in vehicle.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. Battery not charging and '03 Suburban died
    By Snoburbun in forum GM Electrical Tech
    Replies: 13
    Last Post: 09-09-2011, 11:17 PM
  2. Replies: 0
    Last Post: 11-28-2010, 07:46 AM
  3. Replaced alternator, now i'm getting a battery not charging message WTH?
    By obie in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 03-30-2010, 08:51 PM
  4. Battery isolator for 2nd battery
    By Padre in forum Audio, Video & Gadget Tech
    Replies: 16
    Last Post: 11-05-2009, 09:53 AM
  5. Gauges not working- battery not charging [Expired Topic]
    By devildog29 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 05-15-2006, 08:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •