GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 4 of 12 FirstFirst ... 23456 ... Last Post byLast Post by
Results 31 to 40 of 120
  1. #31

    Default

    Quote Originally Posted by ahmitchell1 View Post
    you might not have to replace to throttle positioning sensors. Did you drive thru snow or lots of water when it happened. Next time hit does pop up the door sill plastic piece and see if those wires and that plug in there has moisture on it. If so put dielectric grease on there and see if that helps. Also dry out any water
    I appreciate the help man. Yea it rained the last few weeks down here so that could be it i never thought about that so i will definetly give that a look next time it happens.

  2. #32

    Default

    Anytime. Just noticed you were from Pensacola, I was down there a few weeks ago with the now ex gf and it was pissing rain. Try and find out where the water comes in and seal it up
    2009 chevy 1500 z71 4x4
    2.5 ccm level,2.5 inch rear blocks 305/60/18 coopers stt,Debadged,10 series flow w/dual exit in front or right rear tire, KN CAI, diablo InTune, 18% tint all the way around ,spec-d euro headlights with black housings,winjet smoke LED tail lights,putco LED third brake light smoked, fab fours front bumper with 10k warn winch, RK sports ram air hood
    1965 c10 swb, zz4 350 with the hot cam and fast burn heads and a 780 Holley on top, richmond super street 5 speed,restorod

  3. #33

    Default

    yea its rained alot down here lately its the season lol. and ill try to figure that out and seal it up if thats the problem
    2007 Silverado 1500 Z71 4x4 /Volant Intake/ Superchips Programmer/ Recon LED Tailights/ Rough Country Leveling Kit/ Rough Country 1.5" Body Lift/ Widowpeak 305/75/18s/ Trifecta Tri-fold Tonneau Cover/ Blue LED Interior Lights/ Kenwood 1000 Watt Amp/ 2 500 Watt Kicker 10" Subs

  4. #34

    Default

    Good news I got a letter in the mail and if your having this problem get your truck to the dealership instantly. They will reimburse you for anything you had to pay fixing it and also fix the problem if it is not yet.

    As far as I know it's only for silverados NNBS

  5. #35

    Default

    That would be sweet cause mine is going off everday everytime i start up and wont stop and i really dont have the money to fix it. hopefully my dealership down here got that message. thanks for the heads up ahmitchell1 that will definetly help alot of ppl out.

    - - - Updated - - -

    so i think they are just hooking you up or something because my local chevy dealership said they had no idea about what i was talking about. that they hadnt heard anything about fixing the problem for free or anything like that. did you write chevy or something?
    Last edited by devil_doc7721; 02-01-2013 at 09:54 AM.

  6. #36

    Default

    Evan, My 2012 Silverado had been having an occasional issue with the Traction Control and Stabilitrak being turned off and the warning messages as well as the proverbial "idiot" lights coming on. At first these occurrences seemed to be primarily on colder (but certainly not slick) days and the duration was short, normally happening only once or twice on the 30 minute drive in to work. Recently the warnings have been coming on numerous times with a very noticeable loss of power and the hard clunky shifting of the transmission. The last two days it happened repeatedly on the trip to work and the loss of power was very noticeable. I have also had the engine just up and die on me a few times as I was trying to enter traffic which I find to be extremely dangerous here in Houston and quite alarming. This is an unacceptable situation which could certainly lead to a bad accident trying to get onto the two lane road leading that serves as the exit for our subdivision. I have left a message for my service guy at the dealership but, I can tell you from the obvious long term existence of this TCS issue for GM and the description of how the customers experiencing this issue have been treated... I am very concerned! I can tell you that I had absolutely no issues with my 2007 (non GM) truck and sold it with about 100,000 miles when I got this truck. I only have 18,000 on this new truck and had begun having issues since 7,000 miles or so. It seems some of the reasons quoted for this problem should just not be an acceptable performance standard...blaming a lot of rain for causing such serious issues with a modern vehicle just seems way over the top. I have never had any such problems with numerous other personal vehicles and trucks.

    Quote Originally Posted by GM Customer Service View Post
    JCaddy,

    I'm sorry you are having this issue. Please keep me updated on what you hear from your dealership?

    Evan, GM Customer Service
    Last edited by ChevyFan; 06-24-2013 at 09:46 AM.

  7. #37

    Default

    My 2012 had been having an occassional issue with the Traction Control and Stabilitrak being turned off with the accompanying warning messages as well as the proverbial "idiot" lights coming on. At first these occurrences seemed to be primarily on colder (but certainly not wet or slick) days and the duration of the event was very short, normally happening only once or twice on the 30 minute drive in to work.

    Recently the warnings have been coming on numerous times with a very noticeable loss of power and the hard clunky shifting of the transmission while in this status. The last two days it happened repeatedly on the trip to work and the loss of power was very noticeable. I have also had the engine in this truck just up and die on me a few times as I was trying to enter traffic which I find to be extremely dangerous here in Houston. This is an unacceptable situation which could certainly lead to a bad accident trying to get onto the two lane road leading that serves as the exit for our subdivision. I have left a message for my service guy at the dealership but, I can tell you from the obvious long term existence of this TCS issue for GM and the descriptions posted on some blogs on this issue about how the customers experiencing this issue have been treated by GM and their dealer network... I am very concerned that this may become one of those ongoing issues!
    Last edited by mfleetwood; 08-27-2013 at 02:29 AM.

  8. #38

    Default

    so i dont know if this will help anybody out or it just helped me but i have had my service stabiltrack and and traction controld and brake light on for about 2 or 3 months without them turning off at all. but yesterday i noticed i was pretty below the low line on my brake fluid and so i filled it up to the high line and i havent had the lights or anything come on all day while driving. so i duno if this problem is as easily fixed by something stupid like that but it only takes a second to look and see if your low. im sure it wont fix everybodys problems but hopefully it helps at least some of yall out cuz i was bout to finally take it in to the shop this weekend and probably drop a bunch of money on it but hopefully thats the stupid little fix that helps.

  9. Thanks ChevyFan thanked for this post
  10. #39

    Default

    Jcaddy,

    I have a 2009 Suburban w/ 108k miles and 5 months ago on route 85 the traction control just cut off, both the engine and power-train where running rough and underpowered, the indicator lights where rotating service traction control, and reduced engine power. I limped off the interstate pulled over and checked my fluids (fine). When I restarted it was like it never happened, I called my mechanic who said he had not heard of anything like that happening. When I returned to town, I brought it in and he said the code said TBS sensor issue. Since he could not recreate it he suggested I bring it in the next time it happened. Over the next few months once or twice a month (primarily in the morning) The traction control would turn off, my vehicle would run painfully rough, indicating lights (Service Stabilitrak, Service Traction Control, and Reduced Engine Power) would rotate. Because it always happens when I need to be somewhere I would pull over shut down, and after 5 minutes it would reset.

    As fate would have it I was traveling from NoVa to Raleigh when I had to pull over no less than 5 times on the way down. Needless to say I was on the phones with dealers in Raleigh to find service availability and a throttle body:

    Apparently the throttle body sensor must be replaced with the complete throttle body housing and gasket. The repair priced out to: throttle body $280, Gasket $37 and Labor was $125. Unfortunately for me the service depts were backed up 2-5 days depending on the dealer.

    Since I was staying at a hotel, I went to Autozone and had them pull a code again indicating it was again the TBS sensor, I decided that if I had to replace the throttle body anyways, cleaning it couldn't hurt. I purchased a can of throttle body intake cleaner, I removed the plastic housing 2 tension bands on the front of the engine that covered the throttle body, I then sprayed into the throttle body for 30-40 seconds cleaning as much of the varnish off I could. I was surprised when I started up the vehicle and the check engine light was off (i always thought dealers had to reset), and after 4-5 seconds of the cleaner working through, it ran perfectly. I decided I would repeat for good measure.

    That was 2 months ago and I have not had a re-occurrence since.

    I hope this helps
    Last edited by tpm8; 04-14-2013 at 07:45 PM.

  11. #40

    Default

    There are several reasons why the vehicle will go into "Reduced Power Mode". One of them is when the TPS detects a position mismatch. Basically if it detects something "funny" with the throttle, it will cut it down. This prevents a runaway throttle condition like the one the F-150's had. Replacing the TB is the only way to repair this specific condition. Obviously the fault can come from a generally failed part and/or electrical fault (bad ground, etc.) to a bad PCM, etc etc etc.

Page 4 of 12 FirstFirst ... 23456 ... Last Post byLast Post by

Similar Threads

  1. Reduced engine power help
    By NHRASST1974 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 05-10-2010, 12:41 PM
  2. service stabilitrak after lift blocks in back
    By fornik8her in forum Lifted & Offroad Suspension
    Replies: 2
    Last: 02-26-2010, 04:51 PM
  3. Reduced engine power
    By stuntworks in forum GM Powertrain
    Replies: 2
    Last: 01-11-2010, 07:56 AM
  4. reduced engine power
    By millerahf in forum GM Powertrain
    Replies: 5
    Last: 06-02-2009, 12:28 PM
  5. reduced engine power
    By bisskits in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 09-29-2008, 08:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •