GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 5 of 12 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 114
  1. #41

    Default

    Quote Originally Posted by chipjumper View Post
    There are several reasons why the vehicle will go into "Reduced Power Mode". One of them is when the TPS detects a position mismatch. Basically if it detects something "funny" with the throttle, it will cut it down. This prevents a runaway throttle condition like the one the F-150's had. Replacing the TB is the only way to repair this specific condition. Obviously the fault can come from a generally failed part and/or electrical fault (bad ground, etc.) to a bad PCM, etc etc etc.
    Mine was because of water getting into the IP to body harness. Dried it up,sealed it off, and used some deelectric grease and its hasn't happened in over 30,000 miles
    2009 chevy 1500 z71 4x4
    2.5 ccm level,2.5 inch rear blocks 305/60/18 coopers stt,Debadged,10 series flow w/dual exit in front or right rear tire, KN CAI, diablo InTune, 18% tint all the way around ,spec-d euro headlights with black housings,winjet smoke LED tail lights,putco LED third brake light smoked, fab fours front bumper with 10k warn winch, RK sports ram air hood
    1965 c10 swb, zz4 350 with the hot cam and fast burn heads and a 780 Holley on top, richmond super street 5 speed,restorod

  2. Thanks Steve thanked for this post
  3. #42

    Default

    My 2009 GMC Sierra 1500 did a similar thing. While my daughter was driving it, it threw the codes REDUCED ENGINE POWER, STABILITRAK OFF, SERVICE TRACTION CONTROL, then the low oil pressure light came on and displayed LOW OIL PRESSURE, SHUT OFF ENGINE. My truck has only 36,000 miles on it, but has been recently rebuilt because of a front-end collision (Was totaled by the insurance company and I recently bought it cheaply). The dealer I bought it from took it back and has agreed IN WRITING to fix it. He said today when he scanned it, it showed the mass air sensor is bad & said that could cause a cascading effect. Anyone else see this, too?

  4. #43

    Default

    My 2011 Chevrolet Silverado 1500 4.3L V6 TPS failed when my truck had a bit over 52,000 miles. I was on the hi-way running about 65mph on my way to Springfield, IL to a Horse fair this past March 2013. I noticed a "Service Stabilitrak", "Service Traction Control", "Engine Power is Reduced" as well as the Check engine light on and the low traction warning light on. My speed dropped to approx 40 mph. Engine ran really rough at idle, took for ever to get upto approx. 40mph and the trans was shifting really hard. I limped it to my hotel and limped it to the Chevy dealer in the morning. They found two codes P2135 and P0121, traced to a faulty TPS, they replaced the sensor, reprogrammed the ECM and reset the Idle. They fixed it while I waited to the cost of $257 parts and labor. Not bad as this is my first issue I have had with this truck. I now have a bit over 60,000 miles and that problem never showed itself again. My truck showed zero signs before it went, caught me by surprise.

  5. Likes Steve liked this post
  6. #44

    Default

    My 2010 Tahoe LTZ 14,000 miles crapped out on me three times Friday, with same issue "Service Stabiltrak" "Reduced Engine" and "no traction control. I immediately went to dealer who cannot get me in until Monday, but the service writer indicated this was a common computer malfunction. Like I say, will not know if it is fixed until Monday, but if the problem is this common that a small dealer in Hailey Idaho, was aware, perhaps a recall is in order, or perhaps the problem is bigger than just my vehicle.

  7. #45

    Default

    Quote Originally Posted by rfreder929 View Post
    My 2010 Tahoe LTZ 14,000 miles crapped out on me three times Friday, with same issue "Service Stabiltrak" "Reduced Engine" and "no traction control. I immediately went to dealer who cannot get me in until Monday, but the service writer indicated this was a common computer malfunction. Like I say, will not know if it is fixed until Monday, but if the problem is this common that a small dealer in Hailey Idaho, was aware, perhaps a recall is in order, or perhaps the problem is bigger than just my vehicle.
    Hello rfreder929,

    I apologize for the trouble you experienced with your Tahoe LTZ. I understand how your vehicle breaking down three times in the same day is very frustrating. I see you made an appointment for Monday to bring your vehicle into the dealership. Have you taken your vehicle in yet? Please let us know the status. We can be reached via private message to continue our interaction.

    Sincerely,

    Laura M.
    GM Customer Care

  8. #46

    Wink ISSUE RESOLVED - At least for me

    I was having this issue with my 07 Silverado 4x4 5.3 FF. Stabletrak light, Service traction control, hard shifting, and hard to start. I searched everywhere for a solution but could not find one. For me it ended up being the fuel pump. The dealer wanted to charge me 1100 bucks. I ended up buying a AC Delco pump off Rockbottom.com for 300 with shipping. I am hoping this post helps someone out, because my truck was out of warranty, 86000 miles on it, and I couldn't find any solutions!

  9. Thanks mfleetwood thanked for this post
  10. #47

    Default

    This problem just happened to me earlier today on my 08 Sierra with just 63,200ish miles. I was returning home from the park when I got (Stabilitrak Disabled, Traction Control Disabled, Service Stabilitrak, Service Traction Control). I didn't have any of the other messages labeled or any reduction in RPM's or power. I read through this whole thread and checked my intake connections, checked my brake fluid level along with all the other fluids. I will recheck them all in the morning again along with the door sill someone else mentioned but it hasn't rained in a few days here. I have two shops I'll be taking it to tomorrow if the problem still exist. I don't feel like paying a dealership mechanic to be micromanaged on what they can and can't test for or look at when trying to repair my only vehicle. I'll be back asap to update what i find out also.

    - - - Updated - - -

    OK, So instead of taking it to the dealership I took it to my favorite tire and brake shop. They told me it was a failure in the speed sensor in the right rear tire. It took them about 3 hours and 1 of those hours was going to pick up the new sensor. Total cost from them was $167.00. Hopefully it is solved now. I'll stay posted if it happens again.

  11. #48

    Default

    My 2007 chevy avalanche has been back to the dealer 4x for this same issue. the first two times they told me it was a spark plug that needed to be replaced. the third time they told me there was a memo from GM stating the head gasket was leaking oil into the spark plug casing the engine to misfire. they replaced the gasket seal and the spark plug. last week went back for the same isse 4th time. this time they told me i needed a brand new engine. bought the truck used 2years ago as certified pre owned now netting a free new engine at 89000 miles

  12. #49

    Default

    Quote Originally Posted by willycox420 View Post
    My 2007 chevy avalanche has been back to the dealer 4x for this same issue. the first two times they told me it was a spark plug that needed to be replaced. the third time they told me there was a memo from GM stating the head gasket was leaking oil into the spark plug casing the engine to misfire. they replaced the gasket seal and the spark plug. last week went back for the same isse 4th time. this time they told me i needed a brand new engine. bought the truck used 2years ago as certified pre owned now netting a free new engine at 89000 miles
    We're sorry to hear that it took four trips back and forth to get this diagnosed, willycox420, but it sounds like you're on your way to a pretty good resolution. Keep us posted on the status of the repair.

    Sarah (Assisting Jennifer)
    GM Customer Care

  13. #50

    Default

    Dear ahmitchell1, In Feb 2013 I bought a 2wd crew cab with 64000 mi.. Never a problem, knew man who owned, always serviced.
    As you may know, we have had an immense amount of rain here in S. Carolina that has caused the rivers to rise to over flood stage. I am a catfisher. The road to the river was up to my door covering the step bar. Never had this issue of Stabilitrack service before. After driving through the high water on the road several times, I hit a hill where there was a rattlesnake crossing
    the road and he was huge. I sped up and locked the brakes down on him and the abs kicked in. I backed over him several times
    and when I left him, I kicked it hard to spin tire on him. Later in that same week, when I would turn hard left or right, I would
    get this warning. Come home, park truck, get back in and it may not happen again in several days but it does re-occur. I believe it is directly related to the abs kicking in on that snake and me spinning the tires on him while the body harness was wet
    and could still be holding moisture. My question is can you tell me where that body harness is located and maby send me a pic
    if it is not in an obvious location that you can simply explain, and tell me what to do to get it dried out. I have electrical contact
    cleaner in my shop but I will have to pick up some electrical grease to seal water out. Anything you can do to help will be much
    appreciated. I relate my issue with yours due to the fact that I have never experienced a decrease in engine power, gas mileage, or any other issue. It runs smoothly, idles smoothly, shifts well as it should and just plainly annoys me that the light
    keeps coming on when I am usually on asphalt making a sharp turn. Thanks for any help you can be.

Page 5 of 12 FirstFirst ... 34567 ... LastLast

Similar Threads

  1. Reduced engine power help
    By NHRASST1974 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 05-10-2010, 12:41 PM
  2. service stabilitrak after lift blocks in back
    By fornik8her in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 02-26-2010, 04:51 PM
  3. Reduced engine power
    By stuntworks in forum GM Powertrain
    Replies: 2
    Last Post: 01-11-2010, 07:56 AM
  4. reduced engine power
    By millerahf in forum GM Powertrain
    Replies: 5
    Last Post: 06-02-2009, 12:28 PM
  5. reduced engine power
    By bisskits in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 09-29-2008, 08:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •