GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 9 of 13 FirstFirst ... 7891011 ... Last Post byLast Post by
Results 81 to 90 of 122
  1. #81

    Default

    El-Loco-Diablo,
    Please keep us up to date on any further problems..hopefully the TPS fix is the answer.Great service too!!

  2. #82

    Default

    Just replaced my entire throttle body. I had been experiencing the same problems. Checked the code, TPS. Dealer said they would do it free of charge, so I figured I could return the TPS I had bought and keep my knuckles clean and let a warranty issue solve itself. Well, long day at work with repetitive calls between dealer and GM, they would not cover it, saying it began throwing every electronic code associated with the throttle body. Dealer then wanted to charge me $150 for just an inspection since it amounted to more than just the recalled/warranty TPS. I didn't have "loyalty points" because I perform my own oil changes, so GM and the dealer said, "we are not worried about you and the fleet wide problems associated with this throttle body problem... we want you to buy Japanese". I ended up rolling and letting them rob me for $590. Tired of dealing with it and just vow to take the experience to heart and learn a lesson to treat people honestly. There was already another truck in for the same thing too. Service advisor said they had seen countless TPS codes, tried to change just the sensor, but needed to change the whole throttle body. Check out rockauto.com and get the throttle body for $144, save yourself the agony of battling GM. It is a dangerous item to drive with, limping around town with no power, sad GM doesn't want to help customers. Bought the truck new, only owner. Thanks for the vent. GM, boo.

  3. #83

    Default

    That's too bad craigan. I was told by the dealer at first that it is most likely the throttle body and that it is covered by my warranty providing it had never been totalled in an accident. Here is the letter-

    Hello Doug, The fact that it is going into reduce power mode has nothing to do with the TPS. More likely the issue is a faulty sensor in the throttle body which General Motors has extended the warranty on and your truck would be covered providing it has never been written off in an accident. If you would like further assistance with this please feel free to contact us for an appointment.

    It might still end up being the throttle body, but I am still covered. 2010 Silverado 90,000kms. Is your vehicle older or more miles?

  4. #84

    Default

    I have a 2010 Sierra with 76,000 miles. I was told that had I been going to the dealership for my oil changes they may have helped me out. Same though, no accidents with the vehicle. Maybe GM will work with me on it, it definitely is a fleet wide problem as evidenced by this thread. I will absolutely let everyone know if I get some positive outcome.

  5. #85

    Default

    Had the same trouble with my 2011 Tahoe yesterday but it was -26c below zero.When I started it up after I had been shopping for about 15 minutes the reduced engine power message came on along with the engine check light.The traction control and stabilitrak messages also appeared.Limped into my dealership but the trouble cleared while they were checking it out.These intermittent troubles can be tiring.

  6. #86

    Default

    Quote Originally Posted by El_Loco_Diablo View Post
    Last week in the -37 wind chill it happened over 12 times on the way home. Made it to the local mechanic in time and he scanned it. T.P.S. needed replacing. Monday morning I went to the local dealership. I asked the service manager if they were busy and he said he was already booking for the following Monday. I told him my situation. He said they already had an order for the parts and they would be in the following day(Tuesday). He told me to leave my truck and 9:30 Tuesday morning they called to say my truck was fixed, no charge!
    Big thumbs up to John Bridges in North Battleford, for sneaking me in and taking care of me so quickly.
    Hi El_Loco_Diablo!
    We are glad to hear that your concern was resolved and that you had an amazing dealership experience!
    Please let us know if there is anything I can do to assist you or if you would like for us to let John Bridges know how happy you are.

    Sarah (Assisting Jennifer)
    GM Customer Care

  7. #87

    Default

    Gents----We have a 010 Yukon XL Denali. Experienced the Stabilitrak/Traction Control, Reduced Engine Power combo yesterday. 80,000 miles. I pulled the throttle body off, cleaned it up. It was actually pretty dirty. Same symptoms. Question-should I leave it as it so the codes show when I bring it to the dealer, or disconnect the battery to reset/more safely cover the 8 miles to the dealer? Thanks!

  8. #88

    Default

    I just bought a 2007 Yukon 2 1/2 months ago. Three days ago (Sunday) I came back from a short trip (180 miles total) to my brakes going out and a rotor basically grinding, terribly... Having to work Monday, I had to wait to have my father look at my truck. I went ahead and bought brake pads and a rotor to take to my father, for a quick repair. However, my traction control light came on for service & my engine light is blinking. My dad met me in town and we rode over to the dealer I bought it from and they hooked it up to the computer.

    It came up as cylinder #4. They replaced the injector. I went to pick it up and they said they replaced it but it still did not fix the problem. The computer indicated cylinder #1 this time. Drove my truck on to my dad's and he looked at it and changed one sparkplug and of course the brakes/rotor. He checked the cylinders, stems & valves... No obvious issues.

    My truck still has a miss, the engine rocks and makes a rocking noise AND the service traction control, traction control is off, stabilitrak needs serviced & engine light comes on/stays on. Not to mention, my cruise works on/off and my rear window wiper doesn't work anymore... :-((((

    Can somebody please let me know if you had these similar problems, what worked as far as repair...???
    Thanks!!
    C. Martin
    Quote Originally Posted by mjs84 View Post
    Driving to work this morning my 09 silverado 1500 stalled out twice. Both times the initial indication of "Stabiltrak disabled" came on, followed by "Service Stabilitrak" followed by "Service Traction Control" lastly followed by "Reduce Engine Power" and eventually the engine stalled out leaving me with only manual steering and brakes.

    Has anyone had this issue before? Truck only has 26,000 mi on it... still under warranty... but want to be as prepared for the dealer discussion as possible when I drop it off this evening (if I can make to the dealer).

    Thanks all.
    MJ

    Attachment 53209

  9. #89

    Default


    FINALLY FIXED, "SERVICE STABILITRAK & TRACTION CONTROL DIAGNOSTIC PROBLEM:
    "SERVICE STABILITRAK",
    "SERVICE TRACTION CONTROL",
    "HARD SHIFT 1-2 GEARS"-(STABILITRAK TURNING OFF-CLUNK NOISE)
    "STABILITRAK OFF",
    "TRACTION CONTROL OFF"
    ----------------------------------------------------------------------------------
    CAUSE:
    FUEL WAS 45% ETHANOL @ 85-(COSTCO GAS)-COMPUTER WENT INTO LIMP MODE CAUSING (AFM) TO GET STUCK AND NOT RESET COMPUTER.
    ----------------------------------------------------------------------------------
    SOLUTION:
    DRAINED & CLEANED GAS TANK-
    CHANGED FUEL FILTERS (*ONLY IF NEEDED)
    CLEANED INJECTORS-
    RESET COMPUTER-
    FILLED GAS TANK WITH NO ETHANOL- (Ethanol-free gas stations in the U.S. and Canada)
    TOTAL AMOUNT WITH TAX: $444.86
    ----------------------------------------------------------------------------------
    REFERENCES
    (STABILITRAK CLUNK NOISE): 2010 Silverado stabiliTrak question
    (AFM)-Definition: Active Fuel Management - Wikipedia, the free encyclopedia
    (ETHANOL): Common ethanol fuel mixtures - Wikipedia, the free encyclopedia
    (GAS STATIONS WITHOUT ETHANOL): Ethanol-free gas stations in the U.S. and Canada

  10. #90

    Default

    My 2008 gmc sierra crew cab with 65200 miles, ran fine yesterday and today it hard started, hard shifted 1st and 2nd gear, check engine light came on, stabilitrak off, service stabilitrak light, traction control off light is on. The truck drove terrible, I read this tread looking for help. Lots of good advice. I went and checked my air intake tube and apparently when I changed a headlight last month I left the 2 clamps loose. I guess that compromised my air mixture causing a domino effect over time. I tighten both clamps then started the truck(no hard start), but still had check engine light but no other lights, so I disconnected the battery to clear the check engine light. Test drove the truck ran perfect so far.

Page 9 of 13 FirstFirst ... 7891011 ... Last Post byLast Post by

Similar Threads

  1. Reduced engine power help
    By NHRASST1974 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 05-10-2010, 12:41 PM
  2. service stabilitrak after lift blocks in back
    By fornik8her in forum Lifted & Offroad Suspension
    Replies: 2
    Last: 02-26-2010, 04:51 PM
  3. Reduced engine power
    By stuntworks in forum GM Powertrain
    Replies: 2
    Last: 01-11-2010, 07:56 AM
  4. reduced engine power
    By millerahf in forum GM Powertrain
    Replies: 5
    Last: 06-02-2009, 12:28 PM
  5. reduced engine power
    By bisskits in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 09-29-2008, 08:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •