GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1

    Default Windshield washer fluid won't flow

    2009 Silverado

    Wipers work fine but twist the lever for fluid and none comes out. Any ideas? And yes, i added wiper fluid. In the correct tank.

    Is it possible a hose is disconnected that goes to the washer fluid tank? I looked but couldn't see where it went once inside engine compartment. Point me in any direction?

    Thanks.

  2. #2
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Do you hear it trying to pump the fluid? If not, check the fuse. If the pump is working and you don't notice any fluid coming out, a line could be plugged someplace. If the pump is working, I would also check to see if the fluid level drops after letting it run for a few moments....if it drops, then it sounds like you have a leak or the hose disconnected.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  3. #3
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    I had this problem on my Uplander,found a hose disconnected but still didn't have any fluid coming out.Couldn't hear the pump and no burnt fuse so the dealer ordered a replacement,luckily its not going to cost me any money because its still under warranty.
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

  4. #4
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Quote Originally Posted by Bigbomber View Post
    I had this problem on my Uplander,found a hose disconnected but still didn't have any fluid coming out.Couldn't hear the pump and no burnt fuse so the dealer ordered a replacement,luckily its not going to cost me any money because its still under warranty.
    Interesting..I wonder if the system somehow loses pressure from a disconnected hose and it keeps the pump from pumping? Did the dealer mention what happens when the hose disconnects? Also, was it the hose the dealer replaced or the entire unit? In any case, glad it was under warranty.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  5. #5

    Default

    You live in cold climate? Perhaps water got into lines and it is frozen. ?

  6. #6

    Default

    I do live in Northern Michigan but since the last time i used the windshield washers i don't think its gotten warm enough to get water in the lines i wouldn't think. Gonna check in the morning if there is a fuse for the washer pump because when i twist the wiper lever i hear no noise like the washer pump working so hopefully that will be it.

  7. #7
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Let us know what you come up with....interesting problem.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  8. #8

    Default

    Quote Originally Posted by mfleetwood View Post
    Let us know what you come up with....interesting problem.
    Will do. Thanks for the thoughts.
    After looking through the online owners manual, looks like there is a fuse for the front washer pump (under hood #7). So we'll see what happens when i swap out that fuse.

  9. #9
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    Quote Originally Posted by mfleetwood View Post
    Interesting..I wonder if the system somehow loses pressure from a disconnected hose and it keeps the pump from pumping? Did the dealer mention what happens when the hose disconnects? Also, was it the hose the dealer replaced or the entire unit? In any case, glad it was under warranty.
    He didn't say what happens when the hose disconnects and they replaced the whole unit.
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

  10. #10
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Thanks Bomber!!


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

Page 1 of 3 123 LastLast

Similar Threads

  1. Windshield washer
    By purplehaze in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 13
    Last Post: 08-14-2011, 08:20 AM
  2. Windshield Washer Fluid Lines
    By NcChopper in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 09-06-2010, 08:11 AM
  3. Windshield Washer Fluid Rain-X Bug Remover review
    By Dr_Zero in forum Product Reviews
    Replies: 20
    Last Post: 04-07-2010, 09:05 AM
  4. Windshield Washer Fluid Pump
    By meash20 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last Post: 10-08-2009, 09:34 PM
  5. Windshield Washer Fluid System
    By SilveradoBrett in forum General Chevy & GM Tech Questions
    Replies: 12
    Last Post: 12-08-2008, 06:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •