GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default PO300 Missfire code for constant misfires on # 5 & 6 of a 01 8.1L

    I've got a 01 silverado with an 8.1L that the problem origionally started as a random Crank with no start. It would be totally random too. You could drive it all day then shut it off and it wouldn't start 5 min later. but then 20 min later it will start no problem. does it cold or hot. fuel pressure requlator is good. NOW i started it up this morning and it is runing really rough!!! Check engine light is flashing. Checked the code and it is PO300. Miss fire detected was on cylinders 5 and 6. More on 6 then 5 but 6 is constant misfire and 5 will stop misfiring above about 2 thousand rpms. Any ideas?

  2. #2

    Default

    Quote Originally Posted by bvartyak View Post
    I've got a 01 silverado with an 8.1L that the problem origionally started as a random Crank with no start. It would be totally random too. You could drive it all day then shut it off and it wouldn't start 5 min later. but then 20 min later it will start no problem. does it cold or hot. fuel pressure requlator is good. NOW i started it up this morning and it is runing really rough!!! Check engine light is flashing. Checked the code and it is PO300. Miss fire detected was on cylinders 5 and 6. More on 6 then 5 but 6 is constant misfire and 5 will stop misfiring above about 2 thousand rpms. Any ideas?

    With a Random Multiple Mis-Fire.....It Means that one or more of the following has happened,
    • Faulty spark plugs or wires
    • Faulty coil (pack)
    • Faulty oxygen sensor(s)
    • Faulty fuel injector(s)
    • Burned exhaust valve
    • Faulty catalytic converter(s)
    • Stuck/blocked EGR valve / passages
    • Faulty camshaft position sensor
    • Defective computer

    I would Check the Plugs/Wires first........and then go from there.....also Check all the Wiring and Connectors that lead to the Cylinders.
    Last edited by 99'HEARTBEAT; 12-17-2010 at 12:29 PM.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Ditto to above especially if you havent done a tune up recently. And remeber to Run AC delco plugs.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    I found the problem. It was a faulty Crankshaft Postion Sensor.... NEVER wanna have to replace one of those again! To anyone who ever has to replace one, big help if you can soak it down with penetrating oil for a couple hours!!! The two "O" rings were both seised right up. Could barley even twist it back and forth. Put some penetrating oil on it over night and it came out and had the new one in in about 15 min the next morning. Also be very carefull if you try to pry it out with something!!! I learned the hard way by breaking the top of the sensor off right at the top "O" ring!!! Luckely vice grips would hold onto the electrodes good enough to pull it out!!!

Similar Threads

  1. where to wire to have constant power?
    By RyDogZ71 in forum GM Electrical Tech
    Replies: 7
    Last Post: 09-23-2010, 03:40 PM
  2. info - misfire on a 2001 chevy tahoe 5.3 code PO300
    By x1078p in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 08-18-2009, 11:47 PM
  3. Constant clicking in engine bay
    By jeremiahweed28 in forum GM Powertrain
    Replies: 3
    Last Post: 08-04-2009, 11:20 PM
  4. Repair Help - Silverado misfires in several cylinders
    By chadhenry in forum GM Powertrain
    Replies: 4
    Last Post: 11-20-2007, 12:48 PM
  5. 2001 tahoe rough idle/missfire
    By bracebldrs in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 3
    Last Post: 01-25-2007, 11:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •