GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Hybrid View

  1. #1
    Jr. Apprentice
    Join Date
    Jul 2008
    Location
    Oak Park, Illinois
    Posts
    15

    Default Buzzing motor/pump sound in driver's side footwell

    I have an 05 1500 Suburban. Since it's gotten cold, I've started noticing an intermittent buzzing (sounds/feels like a small pump or electric motor) around the driver's side foot well. It seems to only occur when I pull away from a stop, and it hums for about 2 seconds. Any ideas?
    Kyle Burkhardt
    05 Suburban Z71
    06 VW GTI
    98 BMW M3

  2. #2

    Default

    U sure ir not spinning the tires
    2000 sierra 1500 5.3
    k&n cai
    hypertech programmer
    flowmaster catback
    7" lift 456' s. 35/12.5 nitto teragrapplers
    roll bar. Baha spare tire holder
    brush guard custom tail lights
    full sound system dvd nav

  3. #3
    Jr. Apprentice
    Join Date
    Jul 2008
    Location
    Oak Park, Illinois
    Posts
    15

    Default

    It's definitely coming from the front left. At first, I thought it might be a seized caliper or a bearing, but after paying attention to it, its definitely not those. It sounds like a bad pump (not an electrical buzz).

  4. #4
    Jr. Apprentice
    Join Date
    Dec 2010
    Location
    Brampton, ON Canada
    Posts
    27

    Default

    If you have traction control, perhaps you can turn it off and see if the noice goes away.

  5. #5
    Jr. Apprentice
    Join Date
    Jul 2008
    Location
    Oak Park, Illinois
    Posts
    15

    Default

    If you are implying that it might be the TC coming on because its sensed lost traction, its not. I know what that sounds like, and this is not in low traction circumstances.

  6. #6

    Default

    Try disengaging the traction control using the button, if no change pull the 60amp fuse for the ABS system. When my ABS pack went bad it went intermittent then died and caused the pump to run continually, I pulled the pack and had it rebuilt a pain but worth the effort. The dealers charge about $700 for the job, mine was rebuilt with heavier solenoids for $150. I went without ABS for about a week with shipping back and forth.

    Phil
    Happy 2 Wheeler!

Similar Threads

  1. driver's side rear power window motor out
    By jmb275 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 11-21-2010, 11:36 PM
  2. 98' Silverado Wiper Motor Buzzing, Wipers don't work.... Any ideas?
    By dmaves in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 09-07-2010, 04:42 PM
  3. Buzzing sound when in reverse
    By johnf91 in forum GM Powertrain
    Replies: 0
    Last: 07-26-2010, 11:19 PM
  4. '06 Trailblazer Driver's Side Speaker Problems
    By '10-Silverado in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 03-10-2010, 12:00 PM
  5. Driver's side carpet wet....
    By privateer in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 16
    Last: 04-12-2009, 06:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •