GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 97 Suburban Dies twice in 2 days and restarts immediately, need some help!!!

    Ok, both times the vehicle was stopped and turned off for a minute or so. Then I restarted and put the vehicle into gear and hit the gas and dies after moving a few feet. I put it back into park and turn the key and she fires right up. First time in reverse, then today in drive. Today after it died the electrical system seemed to be pulsing. all the lights and the voltage gauge were pulsing. I turned the key off and then started it right up and drove fine with no problems. I have 14 volts on the voltage gauge and no corrosion on the battery connections. I'm thinking bad ICM or bad ground. This is a 97 5.7 ltr vortec. New plugs, wires, cap, rotor, and fpr within the past year. I don't have any other issues and no CEL came on. Has this happened to you? Do you know what might be causing this? Any help would be appreciated.

    Thanks, Chris
    Thanks, Chris
    97 GMC Suburban
    00 Pontiac Grand Am

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Start with the main chassis ground which is from your main ground on the battery... That is the usual culprit. Ive also heard there is a ground strap on the rear of the pass side head. something else to check. There is most likely nothing wrong with the PCM, i would lean heavly twards a bad ground cable, and possibly the main power cable to the junction box as well as the Alt...
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    ^ I AGREE ^

    and this happened to me last year..it was the main power wire to the junktion box !!!

    But it shure could be any of the above !!

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  4. #4

    Default

    Ok, so the power wire that goes across the upper radiator shroud and into the back of the fuse/relay box? I looked over it previously, but I'll dig a little deeper. If it's that then it's only 8 ft of 8ga power wire and a spade terminal. That'll be an easy fix. I was hoping it wasn't the Ignition Control Module. The alternator going out would still let the truck run off the battery for a little bit, so I wasn't worried about the alternator. I will also check the main ground strap from the battery to the frame. Thanks and keep any suggestions coming.
    Thanks, Chris
    97 GMC Suburban
    00 Pontiac Grand Am

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    I was talking about the cables that run to the alt. and the chassis ground on the pass side of the motor on the frame rail. alot of people have problems with that one. also the cables themselves rot out and corrode and carry current intermittently.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  6. #6

    Default

    Quote Originally Posted by lexisdad1201 View Post
    Ok, so the power wire that goes across the upper radiator shroud and into the back of the fuse/relay box? I looked over it previously, but I'll dig a little deeper. If it's that then it's only 8 ft of 8ga power wire and a spade terminal. That'll be an easy fix. I was hoping it wasn't the Ignition Control Module. The alternator going out would still let the truck run off the battery for a little bit, so I wasn't worried about the alternator. I will also check the main ground strap from the battery to the frame. Thanks and keep any suggestions coming.

    NO, not that power wire..on mine it was on the bottom of the fuseblock the one that feeds the ECM !!! the main 8 foot long had nothing..( THAT WOULD BE TO EASY !!)

    But i am not saying this is your problem tho...
    the e module would be easy ..

    maybe a fuel related issue too ??


    Thats it, i bet its fuelpump related or such....at start up u get pressure and then u hit the gas and the pressure goes bye bye..DIES.
    U restart ( pump builds up press again and it runs )

    I realy think its a fuel issue !!

    A short or something in the fuel pump / relay wiring !!??
    That kind of makes sense...IMO
    Last edited by DAREDEVIL; 12-22-2010 at 10:45 AM.

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  7. #7

    Default

    Well, it hasn't done it again and unless it goes out I have no way to test the fuel pressure. I'll keep an eye out for all these things.
    Thanks, Chris
    97 GMC Suburban
    00 Pontiac Grand Am

  8. #8

    Default

    Well, it finally did it again. Popped the hood and wiggled the ground wire at the battery and she came back to life. Seems like corrosion or loose connection at the ground so I will be changing that out. Thanks for all the help and suggestions.
    Thanks, Chris
    97 GMC Suburban
    00 Pontiac Grand Am

Similar Threads

  1. '02 Suburban dies under load / power
    By kbroderick in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 10-21-2010, 10:40 AM
  2. 2004 Suburban dies while driving
    By skiboat in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 06-28-2010, 05:06 PM
  3. 01 Suburban 8.1 dies
    By HI-TORQ in forum GM Powertrain
    Replies: 2
    Last Post: 05-08-2010, 09:43 PM
  4. 2004 Suburban Dies on the highway
    By jsamotis in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 09-05-2008, 09:48 PM
  5. HELP!- 2003 Silverado engine starts and immediately dies.
    By docpinn in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 14
    Last Post: 08-01-2008, 09:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •