GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: HID issues...

  1. #11

    Default

    i have had 2 sets that had the same problem...i bought them both from the same guy...my lights have stopped flickering but my right side light only comes on when it wants to...i have to turn my lights on and off until it turns on

  2. #12
    Jr. Apprentice amily's Avatar
    Join Date
    Sep 2010
    Location
    Fremont, CA
    Posts
    21

    Default

    you can check the connection. maybe somewhere is loose...

    or switch the two ballasts on each side to check whether the ballast or bulb is defective.....
    live by heart...

  3. #13

    Default

    Quote Originally Posted by jml1022 View Post
    i have had 2 sets that had the same problem...i bought them both from the same guy...my lights have stopped flickering but my right side light only comes on when it wants to...i have to turn my lights on and off until it turns on
    This is the main problem I have with mine too. I switched the bulbs from one side to the other, and it is still the same side that I have issues with, so the problem is in my left side ballast. Based on what you said, I would suspect that for your right side ballast since I have the exact same symptoms.

    2001 Silverado Reg. Cab Not-So-Base -- SOLD
    2003 Avalanche Z71. No Cladding. Check out my Mod thread.
    1974 Triumph Spitfire 1500 - Work in Progress
    2003 Sierra 3500 Duramax. The Newer, Better Work Truck


  4. #14
    Jr. Apprentice amily's Avatar
    Join Date
    Sep 2010
    Location
    Fremont, CA
    Posts
    21

    Default

    maybe, two of his ballasts are defective....
    live by heart...

  5. #15
    Sr. Apprentice Looey's Avatar
    Join Date
    Aug 2009
    Location
    London, Ontario
    Posts
    74

    Default

    Had the same issues. I put a relay in so that the wire coming from the headlight switch only activated the relay, and the power for the hids, came directly from the battery. Also, run the ground wire back to the battery. Problem gone.

  6. #16
    Jr. Mechanic
    Join Date
    Jan 2011
    Location
    Markham, Ontario Canada
    Posts
    111

    Default Ballast for sure

    I have the same issue and coincidentally with the right side. If I cover the automatic light sensor when I start the truck or its dark outside the night comes on but slowly gets brighter. This is an old balast direct wired system that I moved out of my Astro with new bulbs. I figure because of the DRL the wattage may be lower and therefore the ballast doesn't always fire, but once it does, it stays lit. I will be just changing out the balast for a new one when I gte time it it should fix the issue. 55w kits would probably even be worse than my 35W kit.

    Try covering the dash sensor when you start and see if it makes a difference, if it does then probably the right ballast is weak.

  7. #17
    Jr. Apprentice amily's Avatar
    Join Date
    Sep 2010
    Location
    Fremont, CA
    Posts
    21

    Default

    if ur original bulbs are labeled with 35w, just replace the defective ballast with 35w HID ballast considering the issue of compatibility...
    here u go : http://www.vvme.com/hid-replacement-ballasts-c-16.html
    live by heart...

Page 2 of 2 FirstFirst 12

Similar Threads

  1. vss issues 92 k15
    By Snoopius in forum Chevy C/K Truck Forum
    Replies: 19
    Last Post: 10-08-2012, 12:38 PM
  2. two issues
    By HDCLINT7 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 09-17-2009, 05:24 PM
  3. Rim issues
    By Crakums_GT in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 06-17-2009, 11:21 PM
  4. ABS issues
    By hutch_pt in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 05-10-2009, 03:36 PM
  5. ABS Issues?
    By Swatchvy in forum Lifted & Offroad Suspension
    Replies: 9
    Last Post: 03-10-2009, 05:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •